summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-10-07 13:31:26 -0600
committerFlorian Schmaus <flow@gentoo.org>2023-10-18 14:50:44 +0200
commitf301438c7822fcdff251e82b743ee332766c0060 (patch)
tree6a56ab763948a0c4d6a1fb11d46624f45262290b /net-irc/weechat
parentdev-util/bats: drop old (diff)
downloadgentoo-f301438c7822fcdff251e82b743ee332766c0060.tar.gz
gentoo-f301438c7822fcdff251e82b743ee332766c0060.tar.bz2
gentoo-f301438c7822fcdff251e82b743ee332766c0060.zip
net-irc/weechat: add zstd USE-flag
it is optional[1] now [1]: https://github.com/weechat/weechat/commit/6bd0c63192e7acefbb7538a22aa061912cfc06f7 Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 90e2eb2edc62..4983e81b236e 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -32,7 +32,7 @@ PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spe
# dev-lang/php eclass support is lacking, php plugins don't work. bug #705702
SCRIPT_LANGS="guile lua +perl +python ruby tcl"
LANGS=" cs de es fr it ja pl ru"
-IUSE="doc enchant man nls selinux test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+IUSE="doc enchant man nls selinux test +zstd ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="
enchant? ( spell )
@@ -42,7 +42,6 @@ REQUIRED_USE="
"
RDEPEND="
- app-arch/zstd:=
dev-libs/libgcrypt:0=
net-libs/gnutls:=
sys-libs/ncurses:0=
@@ -69,6 +68,7 @@ RDEPEND="
!enchant? ( app-text/aspell )
)
tcl? ( >=dev-lang/tcl-8.4.15:0= )
+ zstd? ( app-arch/zstd:= )
"
DEPEND="${RDEPEND}
@@ -172,6 +172,7 @@ src_configure() {
-DENABLE_TRIGGER=$(usex trigger)
-DENABLE_TYPING=$(usex typing)
-DENABLE_XFER=$(usex xfer)
+ -DENABLE_ZSTD=$(usex zstd)
)
cmake_src_configure
}