summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/xchat-otr
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/xchat-otr')
-rw-r--r--net-irc/xchat-otr/Manifest1
-rw-r--r--net-irc/xchat-otr/metadata.xml9
-rw-r--r--net-irc/xchat-otr/xchat-otr-0.3.ebuild35
3 files changed, 45 insertions, 0 deletions
diff --git a/net-irc/xchat-otr/Manifest b/net-irc/xchat-otr/Manifest
new file mode 100644
index 000000000000..4c863116e322
--- /dev/null
+++ b/net-irc/xchat-otr/Manifest
@@ -0,0 +1 @@
+DIST xchat-otr-0.3.tar.gz 33265 SHA256 7052bc6c9e2487de44f22ad7003f6abc629489380ba3fc358a1c97fe27df06f4 SHA512 0356e5608be4fb7fa4d1a6a3a2f5e71466cc24e42912bb6026dbc82422cb6d633ad160200b2b1427f874d44dff2ddd4e756999879c43f477ab1ca454a151f203 WHIRLPOOL 2360531c8ceecf089a3ad33142ebef4b16ee8f560aecc4b9e06a4abf4f566e8f19fd61e8c6fc0b3b8edd4b3b03a79d3dbc0a56c784a2c5ae1747e03b520b99ae
diff --git a/net-irc/xchat-otr/metadata.xml b/net-irc/xchat-otr/metadata.xml
new file mode 100644
index 000000000000..67e7d510efe5
--- /dev/null
+++ b/net-irc/xchat-otr/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-irc</herd>
+<maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+</maintainer>
+</pkgmetadata>
diff --git a/net-irc/xchat-otr/xchat-otr-0.3.ebuild b/net-irc/xchat-otr/xchat-otr-0.3.ebuild
new file mode 100644
index 000000000000..db9ee1ffa00e
--- /dev/null
+++ b/net-irc/xchat-otr/xchat-otr-0.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit cmake-utils
+
+DESCRIPTION="Off-The-Record messaging (OTR) for xchat"
+HOMEPAGE="http://irssi-otr.tuxfamily.org"
+
+# This should probably be exported by cmake-utils as a variable
+CMAKE_BINARY_DIR="${WORKDIR}"/${PN}_build
+mycmakeargs="-DDOCDIR=/usr/share/doc/${PF}"
+
+SRC_URI="ftp://download.tuxfamily.org/irssiotr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND="<net-libs/libotr-4
+ net-irc/xchat
+ dev-libs/glib:2
+ dev-libs/libgcrypt:0
+ dev-libs/libgpg-error"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-lang/python"
+
+src_install() {
+ cmake-utils_src_install
+ rm "${D}"/usr/share/doc/${PF}/LICENSE
+}