summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-08-27 10:14:54 -0500
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-09-10 18:30:32 -0700
commit152be30612f5d496a98969d7892ddd6b94f6432a (patch)
tree0a17f9e188fce6b3de18addd470f55d6211a5137 /net-irc
parentnet-vpn/wireguard: version bump (diff)
downloadgentoo-152be30612f5d496a98969d7892ddd6b94f6432a.tar.gz
gentoo-152be30612f5d496a98969d7892ddd6b94f6432a.tar.bz2
gentoo-152be30612f5d496a98969d7892ddd6b94f6432a.zip
net-irc/weechat: add missing gnome2_icon_cache_update
Closes: https://github.com/gentoo/gentoo/pull/9710 Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/weechat/weechat-2.2-r1.ebuild (renamed from net-irc/weechat/weechat-2.2.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-irc/weechat/weechat-2.2.ebuild b/net-irc/weechat/weechat-2.2-r1.ebuild
index af107a8fe6bc..ee7ec6e3f6b6 100644
--- a/net-irc/weechat/weechat-2.2.ebuild
+++ b/net-irc/weechat/weechat-2.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
CMAKE_MAKEFILE_GENERATOR=emake
-inherit python-single-r1 cmake-utils
+inherit cmake-utils gnome2-utils python-single-r1
if [[ ${PV} == "9999" ]] ; then
inherit git-r3
@@ -149,3 +149,11 @@ src_configure() {
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}