summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-02-17 17:29:48 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-02-17 17:30:34 +0100
commit369bed9661966b57c15976dcb18ff833df6180ce (patch)
tree05080590dcb4b2051f59832bd83f185a74c5326b /net-irc
parentnet-irc/irssi: version bump. (diff)
downloadgentoo-369bed9661966b57c15976dcb18ff833df6180ce.tar.gz
gentoo-369bed9661966b57c15976dcb18ff833df6180ce.tar.bz2
gentoo-369bed9661966b57c15976dcb18ff833df6180ce.zip
net-irc/irssi-otr: version bump.
Gentoo-Bug: https://bugs.gentoo.org/597384 Gentoo-Bug: https://bugs.gentoo.org/594736 Package-Manager: portage-2.3.3
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/irssi-otr/Manifest1
-rw-r--r--net-irc/irssi-otr/files/irssi-otr-1.0.2-cflags.patch11
-rw-r--r--net-irc/irssi-otr/irssi-otr-1.0.2.ebuild35
3 files changed, 47 insertions, 0 deletions
diff --git a/net-irc/irssi-otr/Manifest b/net-irc/irssi-otr/Manifest
index daf890f8ada5..420f330219aa 100644
--- a/net-irc/irssi-otr/Manifest
+++ b/net-irc/irssi-otr/Manifest
@@ -1 +1,2 @@
DIST irssi-otr-1.0.0.tar.gz 39481 SHA256 bad09a2853ea6fb1a7af42c8f15868fd3ce45f973be90c78944ddf04f8ab517e SHA512 988e50b9df430511ae21a9128ffd27ad27efc102aaa10ec59992c6e642f38dd776396a0768021e3a0588d2a8c30e6316a7b0720d31a05ac21bb47055b0d8c488 WHIRLPOOL 998dc495fb600e635ba342162efc153483fe838d5466995ab248d3c1da358f0cf538d020280157ffffcbe27fbe91b504ed48d1ce28bb396515f560f1fe9197f4
+DIST irssi-otr-1.0.2.tar.gz 40947 SHA256 4619208b9c9171aa97a41960b3e892390b6473e2988a056b9fe8e110daa1ae9c SHA512 983bc861e5d38774305425b412368689f17a1e11298bcef49b9f0ea7a2275b1443ba2ce0a9ef9866e537097f1c6c00e9264085f5cd711f0d78faf252fba18d2f WHIRLPOOL b4684c8617969b5be07c9bd9ea836ce1ca976b425cc357d0c07e2862f162cb84f5206d8cd4347cefb3da9d39a6f8f3faaf577f9c9dafe60494d45ca8189e7dbd
diff --git a/net-irc/irssi-otr/files/irssi-otr-1.0.2-cflags.patch b/net-irc/irssi-otr/files/irssi-otr-1.0.2-cflags.patch
new file mode 100644
index 000000000000..3ab13288e11d
--- /dev/null
+++ b/net-irc/irssi-otr/files/irssi-otr-1.0.2-cflags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac 2014-02-13 04:50:45.000000000 +0400
++++ b/configure.ac 2014-12-07 12:13:17.346849284 +0300
+@@ -64,7 +64,7 @@
+
+ LT_INIT
+
+-CFLAGS="-Wall $CFLAGS -g -fno-strict-aliasing -fstack-protector-all -D_FORTIFY_SOURCE=2 -O1 -Wl,-z,relro,-z,now -fPIE -pie $PACKAGE_CFLAGS"
++CFLAGS="-Wall $CFLAGS -g -fno-strict-aliasing -fstack-protector-all -D_FORTIFY_SOURCE=2 -Wl,-z,relro,-z,now -fPIE -pie $PACKAGE_CFLAGS"
+
+ DEFAULT_INCLUDES="-I\$(top_srcdir) -I\$(top_builddir) -I\$(top_builddir)/src -I\$(top_builddir)/include"
+ AC_SUBST(DEFAULT_INCLUDES)
diff --git a/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild b/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild
new file mode 100644
index 000000000000..57cdcc72a233
--- /dev/null
+++ b/net-irc/irssi-otr/irssi-otr-1.0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
+HOMEPAGE="https://github.com/cryptodotis/irssi-otr"
+SRC_URI="https://github.com/cryptodotis/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libgcrypt-1.7.3
+ >=net-libs/libotr-4.1.0
+ >=net-irc/irssi-1.0.0[perl]"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${P}-cflags.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+ sed -i -e "s|/usr/lib/irssi/modules|/usr/$(get_libdir)/irssi/modules|" configure.ac || die
+}