summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2020-01-04 12:47:14 +0100
committerJohannes Huber <johu@gentoo.org>2020-01-04 12:52:14 +0100
commit39e5421bb559eff29a045d04df45835ea6f17dcd (patch)
tree9e6b3b90b7d4be4706f0368541f3edcb41ccff87 /net-irc
parentapp-portage/hackport: drop old (diff)
downloadgentoo-39e5421bb559eff29a045d04df45835ea6f17dcd.tar.gz
gentoo-39e5421bb559eff29a045d04df45835ea6f17dcd.tar.bz2
gentoo-39e5421bb559eff29a045d04df45835ea6f17dcd.zip
net-irc/quassel: Remove 0.12.5-r2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/Manifest1
-rw-r--r--net-irc/quassel/files/quassel-0.12.5-qt511.patch67
-rw-r--r--net-irc/quassel/metadata.xml4
-rw-r--r--net-irc/quassel/quassel-0.12.5-r2.ebuild184
4 files changed, 0 insertions, 256 deletions
diff --git a/net-irc/quassel/Manifest b/net-irc/quassel/Manifest
index db2b789a3926..1ef7551ac44b 100644
--- a/net-irc/quassel/Manifest
+++ b/net-irc/quassel/Manifest
@@ -1,2 +1 @@
-DIST quassel-0.12.5.tar.bz2 3747392 BLAKE2B 624cd18c2a5e1c480f701072bfeeeb18589cdbd2f2b7ab0d524f32e384ac4feb7328b23b60c3005340d53e4bf3a209f75a5d673a8d5d3f659825f0ef21bd3f9f SHA512 3a0263d7bec9ef4b0d8ef6ea53784f95e0efbadc0f03b49005908411b0b53543ebc66189fb4100c117d87264b648f2a1b01be48c371f926b9f326b1ffc870685
DIST quassel-0.13.1.tar.bz2 4289663 BLAKE2B 1d5252efe3febd26e7d04f6533f551316d58b5e4a7c143cc81dd0cf6a3602e28a57de4c73c86fb668e43bf8d01049456d1f5cf37a73f683b9c8b6dd9d78ee4bd SHA512 4ed55e81b1638c8851ddae5d9c9d23a1c2cea92f307e19f426873c2600d8e183898d3ed7c290f2ea5d1b8c5e1be7f9ffcc3e8c3c0193d080fc879b10cc3a962c
diff --git a/net-irc/quassel/files/quassel-0.12.5-qt511.patch b/net-irc/quassel/files/quassel-0.12.5-qt511.patch
deleted file mode 100644
index c46eee8e29b8..000000000000
--- a/net-irc/quassel/files/quassel-0.12.5-qt511.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-commit 0cc8e1431feb739d0727f0131c87a7ecbe336a81
-Author: Manuel Nickschas <sputnick@quassel-irc.org>
-Date: Thu May 3 23:19:34 2018 +0200
-
- cmake: Fix build with Qt 5.11
-
- Qt 5.11 removes the qt5_use_modules function, so add a copy. If
- present, the Qt-provided function will be used instead.
-
- Closes GH-355.
-
-diff --git a/cmake/QuasselMacros.cmake b/cmake/QuasselMacros.cmake
-index 652c0042..d77ba1cf 100644
---- a/cmake/QuasselMacros.cmake
-+++ b/cmake/QuasselMacros.cmake
-@@ -5,6 +5,9 @@
- # The qt4_use_modules function was taken from CMake's Qt4Macros.cmake:
- # (C) 2005-2009 Kitware, Inc.
- #
-+# The qt5_use_modules function was taken from Qt 5.10.1 (and modified):
-+# (C) 2005-2011 Kitware, Inc.
-+#
- # Redistribution and use is allowed according to the terms of the BSD license.
- # For details see the accompanying COPYING-CMAKE-SCRIPTS file.
-
-@@ -43,6 +46,41 @@ function(qt4_use_modules _target _link_type)
- endforeach()
- endfunction()
-
-+# Qt 5.11 removed the qt5_use_modules function, so we need to provide it until we can switch to a modern CMake version.
-+# If present, the Qt-provided version will be used automatically instead.
-+function(qt5_use_modules _target _link_type)
-+ if (NOT TARGET ${_target})
-+ message(FATAL_ERROR "The first argument to qt5_use_modules must be an existing target.")
-+ endif()
-+ if ("${_link_type}" STREQUAL "LINK_PUBLIC" OR "${_link_type}" STREQUAL "LINK_PRIVATE" )
-+ set(_qt5_modules ${ARGN})
-+ set(_qt5_link_type ${_link_type})
-+ else()
-+ set(_qt5_modules ${_link_type} ${ARGN})
-+ endif()
-+
-+ if ("${_qt5_modules}" STREQUAL "")
-+ message(FATAL_ERROR "qt5_use_modules requires at least one Qt module to use.")
-+ endif()
-+ foreach(_module ${_qt5_modules})
-+ if (NOT Qt5${_module}_FOUND)
-+ find_package(Qt5${_module} PATHS "${_Qt5_COMPONENT_PATH}" NO_DEFAULT_PATH)
-+ if (NOT Qt5${_module}_FOUND)
-+ message(FATAL_ERROR "Can not use \"${_module}\" module which has not yet been found.")
-+ endif()
-+ endif()
-+ target_link_libraries(${_target} ${_qt5_link_type} ${Qt5${_module}_LIBRARIES})
-+ set_property(TARGET ${_target} APPEND PROPERTY INCLUDE_DIRECTORIES ${Qt5${_module}_INCLUDE_DIRS})
-+ set_property(TARGET ${_target} APPEND PROPERTY COMPILE_DEFINITIONS ${Qt5${_module}_COMPILE_DEFINITIONS})
-+ if (Qt5_POSITION_INDEPENDENT_CODE
-+ AND (CMAKE_VERSION VERSION_LESS 2.8.12
-+ AND (NOT CMAKE_CXX_COMPILER_ID STREQUAL "GNU"
-+ OR CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)))
-+ set_property(TARGET ${_target} PROPERTY POSITION_INDEPENDENT_CODE ${Qt5_POSITION_INDEPENDENT_CODE})
-+ endif()
-+ endforeach()
-+endfunction()
-+
- # Some wrappers for simplifying dual-Qt support
-
- function(qt_use_modules)
diff --git a/net-irc/quassel/metadata.xml b/net-irc/quassel/metadata.xml
index a343c531e402..57498aeffbe6 100644
--- a/net-irc/quassel/metadata.xml
+++ b/net-irc/quassel/metadata.xml
@@ -30,10 +30,6 @@
<flag name="oxygen">
Support the Oxygen icon set that was the default for KDE4.
</flag>
- <flag name="phonon">
- Build client with phonon backend support. This enables sound
- playback in client.
- </flag>
<flag name="server">
Build the server binary. If this USE flag is disabled, the
'core' server binary for quassel is not built, and cannot be
diff --git a/net-irc/quassel/quassel-0.12.5-r2.ebuild b/net-irc/quassel/quassel-0.12.5-r2.ebuild
deleted file mode 100644
index 5db277fc20a5..000000000000
--- a/net-irc/quassel/quassel-0.12.5-r2.ebuild
+++ /dev/null
@@ -1,184 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils gnome2-utils pax-utils systemd user versionator
-
-if [[ ${PV} != *9999* ]]; then
- SRC_URI="https://quassel-irc.org/pub/${P}.tar.bz2"
- KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~sparc-solaris"
-else
- EGIT_REPO_URI=( "https://github.com/${PN}/${PN}" "git://git.${PN}-irc.org/${PN}" )
- inherit git-r3
-fi
-
-DESCRIPTION="Qt/KDE IRC client supporting a remote daemon for 24/7 connectivity"
-HOMEPAGE="https://quassel-irc.org/"
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="crypt dbus debug kde monolithic phonon postgres +server
-snorenotify +ssl syslog urlpreview X"
-
-SERVER_RDEPEND="
- dev-qt/qtscript:5
- crypt? ( app-crypt/qca:2[qt5(+),ssl] )
- postgres? ( dev-qt/qtsql:5[postgres] )
- !postgres? ( dev-qt/qtsql:5[sqlite] dev-db/sqlite:3[threadsafe(+),-secure-delete] )
- syslog? ( virtual/logger )
-"
-
-GUI_RDEPEND="
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dbus? (
- >=dev-libs/libdbusmenu-qt-0.9.3_pre20140619[qt5(+)]
- dev-qt/qtdbus:5
- )
- kde? (
- kde-frameworks/kconfigwidgets:5
- kde-frameworks/kcoreaddons:5
- kde-frameworks/knotifications:5
- kde-frameworks/knotifyconfig:5
- kde-frameworks/ktextwidgets:5
- kde-frameworks/kwidgetsaddons:5
- kde-frameworks/kxmlgui:5
- kde-frameworks/sonnet:5
- )
- phonon? ( media-libs/phonon[qt5(+)] )
- snorenotify? ( >=x11-libs/snorenotify-0.7.0 )
- urlpreview? ( dev-qt/qtwebengine:5[widgets] )
-"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5[ssl?]
- sys-libs/zlib
- monolithic? (
- ${SERVER_RDEPEND}
- ${GUI_RDEPEND}
- )
- !monolithic? (
- server? ( ${SERVER_RDEPEND} )
- X? ( ${GUI_RDEPEND} )
- )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- kde-frameworks/extra-cmake-modules
-"
-
-DOCS=( AUTHORS ChangeLog README.md )
-
-REQUIRED_USE="
- || ( X server monolithic )
- crypt? ( || ( server monolithic ) )
- dbus? ( || ( X monolithic ) )
- kde? ( || ( X monolithic ) dbus phonon )
- phonon? ( || ( X monolithic ) )
- postgres? ( || ( server monolithic ) )
- snorenotify? ( || ( X monolithic ) )
- syslog? ( || ( server monolithic ) )
-"
-
-PATCHES=( "${FILESDIR}/${P}-qt511.patch" )
-
-pkg_setup() {
- if use server; then
- QUASSEL_DIR=/var/lib/${PN}
- QUASSEL_USER=${PN}
- # create quassel:quassel user
- enewgroup "${QUASSEL_USER}"
- enewuser "${QUASSEL_USER}" -1 -1 "${QUASSEL_DIR}" "${QUASSEL_USER}"
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_QT5=ON
- -DEMBED_DATA=OFF
- -DCMAKE_SKIP_RPATH=ON
- -DWITH_WEBKIT=OFF
- $(cmake-utils_use_find_package crypt QCA2-QT5)
- $(cmake-utils_use_find_package dbus dbusmenu-qt5)
- $(cmake-utils_use_find_package dbus Qt5DBus)
- -DWITH_KDE=$(usex kde)
- -DWITH_OXYGEN=$(usex !kde)
- -DWANT_MONO=$(usex monolithic)
- $(cmake-utils_use_find_package phonon Phonon4Qt5)
- -DWANT_CORE=$(usex server)
- $(cmake-utils_use_find_package snorenotify LibsnoreQt5)
- -DWITH_WEBENGINE=$(usex urlpreview)
- -DWANT_QTCLIENT=$(usex X)
- )
-
- # Something broke upstream detection since Qt 5.5
- if use ssl ; then
- mycmakeargs+=( "-DHAVE_SSL=TRUE" )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use server ; then
- # needs PAX marking wrt bug#346255
- pax-mark m "${ED}/usr/bin/quasselcore"
-
- # prepare folders in /var/
- keepdir "${QUASSEL_DIR}"
- fowners "${QUASSEL_USER}":"${QUASSEL_USER}" "${QUASSEL_DIR}"
-
- # init scripts & systemd unit
- newinitd "${FILESDIR}"/quasselcore.init-r1 quasselcore
- newconfd "${FILESDIR}"/quasselcore.conf-r1 quasselcore
- systemd_dounit "${FILESDIR}"/quasselcore.service
-
- # logrotate
- insinto /etc/logrotate.d
- newins "${FILESDIR}/quassel.logrotate" quassel
- fi
-}
-
-pkg_postinst() {
- if use monolithic && use ssl ; then
- elog "Information on how to enable SSL support for client/core connections"
- elog "is available at http://bugs.quassel-irc.org/projects/quassel-irc/wiki/Client-Core_SSL_support."
- fi
-
- if use server; then
- einfo "If you want to generate SSL certificate remember to run:"
- einfo " emerge --config =${CATEGORY}/${PF}"
- fi
-
- if use server || use monolithic ; then
- einfo "Quassel can use net-misc/oidentd package if installed on your system."
- einfo "Consider installing it if you want to run quassel within identd daemon."
- fi
-
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}
-
-pkg_config() {
- if use server && use ssl; then
- # generate the pem file only when it does not already exist
- if [ ! -f "${QUASSEL_DIR}/quasselCert.pem" ]; then
- einfo "Generating QUASSEL SSL certificate to: \"${QUASSEL_DIR}/quasselCert.pem\""
- openssl req -x509 -nodes -days 365 -newkey rsa:2048 \
- -keyout "${QUASSEL_DIR}/quasselCert.pem" \
- -out "${QUASSEL_DIR}/quasselCert.pem"
- # permissions for the key
- chown ${QUASSEL_USER}:${QUASSEL_USER} "${QUASSEL_DIR}/quasselCert.pem"
- chmod 400 "${QUASSEL_DIR}/quasselCert.pem"
- else
- einfo "Certificate \"${QUASSEL_DIR}/quasselCert.pem\" already exists."
- einfo "Remove it if you want to create new one."
- fi
- fi
-}