summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-25 07:07:29 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-25 07:07:29 +0200
commit7e59eb971d6c83343ba5c3173ae48bb11acc5aa3 (patch)
tree89b44cf8c43a8b1953f6058bfcb0fb1c9c5e21b1 /net-irc
parentdev-ruby/dotenv: add 2.4.0 (diff)
downloadgentoo-7e59eb971d6c83343ba5c3173ae48bb11acc5aa3.tar.gz
gentoo-7e59eb971d6c83343ba5c3173ae48bb11acc5aa3.tar.bz2
gentoo-7e59eb971d6c83343ba5c3173ae48bb11acc5aa3.zip
net-irc/quassel: Remove 0.12.4 (r0)
Bug: https://bugs.gentoo.org/603414 Bug: https://bugs.gentoo.org/653834 Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/quassel/files/quasselcore.conf21
-rw-r--r--net-irc/quassel/files/quasselcore.init62
-rw-r--r--net-irc/quassel/quassel-0.12.4.ebuild173
3 files changed, 0 insertions, 256 deletions
diff --git a/net-irc/quassel/files/quasselcore.conf b/net-irc/quassel/files/quasselcore.conf
deleted file mode 100644
index 960203500fe4..000000000000
--- a/net-irc/quassel/files/quasselcore.conf
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# Loglevel Debug|Info|Warning|Error. Default is: Info
-# The logfile is located at /var/log/quassel.log.
-#LOGLEVEL="Info"
-
-# The address(es) quasselcore will listen on. Default is 0.0.0.0
-#LISTEN="0.0.0.0"
-
-# The port quasselcore will listen at. Default is: 4242
-#PORT="4242"
-
-# User we want our daemon to run under.
-#QUASSEL_USER="quassel"
-
-# Directory we store all quasselcore content.
-#CONFIGDIR="/var/lib/quassel"
-
-# File quasselcore will log all its events into.
-#LOGFILE="/var/log/quassel.log"
diff --git a/net-irc/quassel/files/quasselcore.init b/net-irc/quassel/files/quasselcore.init
deleted file mode 100644
index 8e66dff8ca32..000000000000
--- a/net-irc/quassel/files/quasselcore.init
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need localmount net
- after bootmisc postgresql
-}
-
-CORE="$(which quasselcore)"
-PID="/var/run/quassel.pid"
-LOGFILE=${LOGFILE:-"/var/log/quassel.log"}
-CONFIGDIR=${CONFIGDIR:-"/var/lib/quassel"}
-QUASSEL_USER=${QUASSEL_USER:-"quassel"}
-
-checkconfig() {
- # set defaults
- LOGLEVEL=${LOGLEVEL:-"Info"}
-
- # check config folder
- if [ ! -d "${CONFIGDIR}" ]; then
- mkdir "${CONFIGDIR}" || return 1
- fi
- # permissions always changed just to avoid runtime issues
- chown -R "${QUASSEL_USER}":"${QUASSEL_USER}" "${CONFIGDIR}" || return 1
-
- # check log file
- if [ ! -e "${LOGFILE}" ]; then
- touch "${LOGFILE}" || return 1
- fi
- # permissions always changed just to avoid runtime issues
- chown "${QUASSEL_USER}":"${QUASSEL_USER}" "${LOGFILE}" || return 1
-}
-
-start() {
- checkconfig || return 1
-
- ebegin "Starting Quassel Core"
-
- if [ -n "${RC_UNAME}" ]; then
- # running on baselayout-2/openrc
- start-stop-daemon --start --user "${QUASSEL_USER}" --background --make-pidfile \
- --pidfile "${PID}" \
- --exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
- ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
- --configdir="${CONFIGDIR}"
- else
- # running on baselayout-1
- start-stop-daemon --start --chuid "${QUASSEL_USER}" --background --make-pidfile \
- --pidfile "${PID}" --env HOME="${CONFIGDIR}" \
- --exec "${CORE}" -- --logfile="${LOGFILE}" --loglevel="${LOGLEVEL}" \
- ${LISTEN:+--listen="${LISTEN}"} ${PORT:+--port="${PORT}"} \
- --configdir="${CONFIGDIR}"
- fi
- eend $?
-}
-
-stop() {
- ebegin "Stopping Quassel Core"
- start-stop-daemon --stop --pidfile "${PID}" --exec "${CORE}"
- eend $?
-}
diff --git a/net-irc/quassel/quassel-0.12.4.ebuild b/net-irc/quassel/quassel-0.12.4.ebuild
deleted file mode 100644
index fea12b014b0b..000000000000
--- a/net-irc/quassel/quassel-0.12.4.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils eutils pax-utils systemd user versionator
-
-EGIT_REPO_URI=( "https://github.com/${PN}/${PN}" "git://git.${PN}-irc.org/${PN}" )
-[[ "${PV}" == "9999" ]] && inherit git-r3
-
-DESCRIPTION="Qt/KDE IRC client supporting a remote daemon for 24/7 connectivity"
-HOMEPAGE="http://quassel-irc.org/"
-[[ "${PV}" == "9999" ]] || SRC_URI="http://quassel-irc.org/pub/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-KEYWORDS="amd64 ~arm ~ppc x86 ~amd64-linux ~sparc-solaris"
-SLOT="0"
-IUSE="crypt dbus debug kde monolithic phonon postgres +server
-snorenotify +ssl syslog webkit X"
-
-SERVER_RDEPEND="
- dev-qt/qtscript:5
- crypt? ( app-crypt/qca:2[qt5(+),ssl] )
- postgres? ( dev-qt/qtsql:5[postgres] )
- !postgres? ( dev-qt/qtsql:5[sqlite] dev-db/sqlite:3[threadsafe(+),-secure-delete] )
- syslog? ( virtual/logger )
-"
-
-GUI_RDEPEND="
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dbus? (
- >=dev-libs/libdbusmenu-qt-0.9.3_pre20140619[qt5(+)]
- dev-qt/qtdbus:5
- )
- kde? (
- kde-frameworks/kconfigwidgets:5
- kde-frameworks/kcoreaddons:5
- kde-frameworks/knotifications:5
- kde-frameworks/knotifyconfig:5
- kde-frameworks/ktextwidgets:5
- kde-frameworks/kwidgetsaddons:5
- kde-frameworks/kxmlgui:5
- kde-frameworks/sonnet:5
- )
- phonon? ( media-libs/phonon[qt5(+)] )
- snorenotify? ( >=x11-libs/snorenotify-0.7.0 )
- webkit? ( dev-qt/qtwebkit:5 )
-"
-
-RDEPEND="
- dev-qt/qtcore:5
- dev-qt/qtnetwork:5[ssl?]
- sys-libs/zlib
- monolithic? (
- ${SERVER_RDEPEND}
- ${GUI_RDEPEND}
- )
- !monolithic? (
- server? ( ${SERVER_RDEPEND} )
- X? ( ${GUI_RDEPEND} )
- )
-"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5
- kde-frameworks/extra-cmake-modules
-"
-
-DOCS=( AUTHORS ChangeLog README )
-
-REQUIRED_USE="
- || ( X server monolithic )
- crypt? ( || ( server monolithic ) )
- dbus? ( || ( X monolithic ) )
- kde? ( || ( X monolithic ) phonon )
- phonon? ( || ( X monolithic ) )
- postgres? ( || ( server monolithic ) )
- snorenotify? ( || ( X monolithic ) )
- syslog? ( || ( server monolithic ) )
- webkit? ( || ( X monolithic ) )
-"
-
-pkg_setup() {
- if use server; then
- QUASSEL_DIR=/var/lib/${PN}
- QUASSEL_USER=${PN}
- # create quassel:quassel user
- enewgroup "${QUASSEL_USER}"
- enewuser "${QUASSEL_USER}" -1 -1 "${QUASSEL_DIR}" "${QUASSEL_USER}"
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package crypt QCA2-QT5)
- $(cmake-utils_use_find_package dbus dbusmenu-qt5)
- -DWITH_KDE=$(usex kde)
- -DWITH_OXYGEN=$(usex !kde)
- -DWANT_MONO=$(usex monolithic)
- $(cmake-utils_use_find_package phonon Phonon4Qt5)
- -DUSE_QT5=ON
- -DWANT_CORE=$(usex server)
- $(cmake-utils_use_find_package snorenotify LibsnoreQt5)
- -DWITH_WEBKIT=$(usex webkit)
- -DWANT_QTCLIENT=$(usex X)
- -DEMBED_DATA=OFF
- -DCMAKE_SKIP_RPATH=ON
- )
-
- # Something broke upstream detection since Qt 5.5
- if use ssl ; then
- mycmakeargs+=("-DHAVE_SSL=TRUE")
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use server ; then
- # needs PAX marking wrt bug#346255
- pax-mark m "${ED}/usr/bin/quasselcore"
-
- # prepare folders in /var/
- keepdir "${QUASSEL_DIR}"
- fowners "${QUASSEL_USER}":"${QUASSEL_USER}" "${QUASSEL_DIR}"
-
- # init scripts & systemd unit
- newinitd "${FILESDIR}"/quasselcore.init quasselcore
- newconfd "${FILESDIR}"/quasselcore.conf quasselcore
- systemd_dounit "${FILESDIR}"/quasselcore.service
-
- # logrotate
- insinto /etc/logrotate.d
- newins "${FILESDIR}/quassel.logrotate" quassel
- fi
-}
-
-pkg_postinst() {
- if use monolithic && use ssl ; then
- elog "Information on how to enable SSL support for client/core connections"
- elog "is available at http://bugs.quassel-irc.org/wiki/quassel-irc."
- fi
-
- if use server; then
- einfo "If you want to generate SSL certificate remember to run:"
- einfo " emerge --config =${CATEGORY}/${PF}"
- fi
-
- if use server || use monolithic ; then
- einfo "Quassel can use net-misc/oidentd package if installed on your system."
- einfo "Consider installing it if you want to run quassel within identd daemon."
- fi
-}
-
-pkg_config() {
- if use server && use ssl; then
- # generate the pem file only when it does not already exist
- if [ ! -f "${QUASSEL_DIR}/quasselCert.pem" ]; then
- einfo "Generating QUASSEL SSL certificate to: \"${QUASSEL_DIR}/quasselCert.pem\""
- openssl req -x509 -nodes -days 365 -newkey rsa:2048 \
- -keyout "${QUASSEL_DIR}/quasselCert.pem" \
- -out "${QUASSEL_DIR}/quasselCert.pem"
- # permissions for the key
- chown ${QUASSEL_USER}:${QUASSEL_USER} "${QUASSEL_DIR}/quasselCert.pem"
- chmod 400 "${QUASSEL_DIR}/quasselCert.pem"
- else
- einfo "Certificate \"${QUASSEL_DIR}/quasselCert.pem\" already exists."
- einfo "Remove it if you want to create new one."
- fi
- fi
-}