summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNathan Phillip Brink <binki@gentoo.org>2016-08-20 19:35:18 +0000
committerNathan Phillip Brink <binki@gentoo.org>2016-08-20 19:35:18 +0000
commit857a5ec86c3a12a7285501e795af53b1d70340b8 (patch)
treeb8f90cd92b2ec18159caa97789bb16776f55b151 /net-irc
parentprofiles: mask kde-apps/kwalletd-pam for removal (diff)
downloadgentoo-857a5ec86c3a12a7285501e795af53b1d70340b8.tar.gz
gentoo-857a5ec86c3a12a7285501e795af53b1d70340b8.tar.bz2
gentoo-857a5ec86c3a12a7285501e795af53b1d70340b8.zip
net-irc/unrealircd: Major version bump to unrealircd-4.0.5.
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/unrealircd/Manifest1
-rw-r--r--net-irc/unrealircd/files/unrealircd.confd-r236
-rw-r--r--net-irc/unrealircd/files/unrealircd.initd-r144
-rw-r--r--net-irc/unrealircd/unrealircd-4.0.5.ebuild222
4 files changed, 303 insertions, 0 deletions
diff --git a/net-irc/unrealircd/Manifest b/net-irc/unrealircd/Manifest
index 36f258fbc672..89dbdc1ab84c 100644
--- a/net-irc/unrealircd/Manifest
+++ b/net-irc/unrealircd/Manifest
@@ -1 +1,2 @@
DIST Unreal3.2.10.4.tar.gz 3540227 SHA256 5041b67745d0bd2072cf9b74c07853085b8b5b07330263f0986bdc56eda98aa8 SHA512 eeecefe79cadf3efa1b9379d4b675c0b86a2dd91e703f9e4b3998331f56b923d3719c67482f464f9b1699f801e0a83d677ada642ea7037c52a9d5db63abe6a5c WHIRLPOOL e52949bb6b20076d382825a841c8f643f1f64ac265d7f58898a6417c4853b569b8f561d5dccf198b4f006725e4be0636a2edb580023e8db62dadab8397d11975
+DIST unrealircd-4.0.5.tar.gz 4877444 SHA256 5b69bbeb3487e98df2f6506d0455ce62f069281c88b937caf4e32f4f92a42717 SHA512 503c55b901531bb984c6cfbeaaf560da714248ff716717671e09442f5a9fa245cd872ae69d08533419fb94efab98e9f80ae4f33c62522c246da6e877971b2a38 WHIRLPOOL 1fc4e16e4c12035758c673b88effd660766ab2bff56999ebaced6be1acb0b4a6c69efd3cd90ffaa63ee6479adda6e16cc415640322a4a66346e5bb182b795178
diff --git a/net-irc/unrealircd/files/unrealircd.confd-r2 b/net-irc/unrealircd/files/unrealircd.confd-r2
new file mode 100644
index 000000000000..dd7e7b4204b0
--- /dev/null
+++ b/net-irc/unrealircd/files/unrealircd.confd-r2
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# user to run unrealircd as
+UNREALIRCD_USER="unrealircd"
+
+# Which configuration file to load instead of unrealircd.conf. If you
+# want to run multiple instances of unrealircd, you must edit
+# files::pidfile to match UNREALIRCD_PIDFILE. You should also ensure
+# that files::tunefile is different for each unrealircd instance. See
+# https://www.unrealircd.org/docs/Configuration#Files_block
+#
+# To support multiple instances of unrealircd, you may create symlinks
+# in /etc/init.d pointing to /etc/init.d/unrealircd. It is recommended
+# that the scheme unrealircd.${instance_name} be used. For each
+# instance, you may make a copy of this file with the appropriate name
+# to override default options specific to that instance.
+UNREALIRCD_CONF="/etc/unrealircd/${SVCNAME}.conf"
+
+# The path where unrealircd is configured to create its pidfile.
+UNREALIRCD_PIDFILE="/var/run/unrealircd/${SVCNAME#unreal}.pid"
+
+# extra options to pass to unrealircd ...
+# You should not specify the -f option here; use
+# UNREALIRCD_CONF instead.
+#
+# [-h servername]
+# [-p portnumber]
+# [-x loglevel]
+# [-t] (to enable debug output)
+UNREALIRCD_OPTS=""
+
+# Extra flags to pass to start-stop-daemon. When initially
+# debugging, removing --quiet may help.
+UNREALIRCD_SSD_OPTS="--quiet"
diff --git a/net-irc/unrealircd/files/unrealircd.initd-r1 b/net-irc/unrealircd/files/unrealircd.initd-r1
new file mode 100644
index 000000000000..381723fc307f
--- /dev/null
+++ b/net-irc/unrealircd/files/unrealircd.initd-r1
@@ -0,0 +1,44 @@
+#!/sbin/openrc-run
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+
+# Defaults
+: ${UNREALIRCD_USER:=unrealircd}
+: ${UNREALIRCD_CONF:=/etc/unrealircd/${SVCNAME}.conf}
+: ${UNREALIRCD_PIDFILE:=/run/unrealircd/${SVCNAME#unreal}.pid}
+
+depend() {
+ use dns net
+ provide ircd
+}
+
+start() {
+ UNREALIRCD_PIDFILEDIR=${UNREALIRCD_PIDFILE%/*}
+ if ! [ -d "${UNREALIRCD_PIDFILEDIR}" ]; then
+ ebegin "Creating ${UNREALIRCD_PIDFILEDIR} for ${SVCNAME}"
+ mkdir "${UNREALIRCD_PIDFILEDIR}" \
+ && chown :unrealircd "${UNREALIRCD_PIDFILEDIR}" \
+ && chmod 770 "${UNREALIRCD_PIDFILEDIR}"
+ eend $?
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start ${UNREALIRCD_SSD_OPTS} --exec /usr/bin/unrealircd \
+ --user ${UNREALIRCD_USER} --pidfile "${UNREALIRCD_PIDFILE}" -- -f "${UNREALIRCD_CONF}" ${UNREALIRCD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop ${UNREALIRCD_SSD_OPTS} --pidfile "${UNREALIRCD_PIDFILE}"
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP ${UNREALIRCD_SSD_OPTS} --pidfile "${UNREALIRCD_PIDFILE}"
+ eend $?
+}
diff --git a/net-irc/unrealircd/unrealircd-4.0.5.ebuild b/net-irc/unrealircd/unrealircd-4.0.5.ebuild
new file mode 100644
index 000000000000..ab6bacdf5f51
--- /dev/null
+++ b/net-irc/unrealircd/unrealircd-4.0.5.ebuild
@@ -0,0 +1,222 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils ssl-cert versionator multilib user
+
+DESCRIPTION="An advanced Internet Relay Chat daemon"
+HOMEPAGE="https://www.unrealircd.org/"
+SRC_URI="https://www.unrealircd.org/${PN}$(get_version_component_range 1)/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="class-nofakelag curl +extban-stacking +operoverride operoverride-verify +prefixaq
+ showlistmodes shunnotices ssl topicisnuhost +usermod"
+
+RDEPEND="ssl? ( dev-libs/openssl:= )
+ curl? ( net-misc/curl[adns] )
+ dev-libs/libpcre2
+ dev-libs/tre
+ >=net-dns/c-ares-1.7"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_pretend() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ version_is_at_least 4 "${v}" && continue
+ ewarn "The configuration file format has changed since ${v}."
+ ewarn "Please be prepared to manually update them and visit:"
+ ewarn "https://www.unrealircd.org/docs/Upgrading_from_3.2.x"
+ break
+ done
+}
+
+pkg_setup() {
+ enewuser unrealircd
+}
+
+src_prepare() {
+ # QA check against bundled pkgs
+ rm -r extras || die
+
+ if use class-nofakelag; then
+ sed -i -e 's:#undef\( FAKELAG_CONFIGURABLE\):#define\1:' include/config.h || die
+ fi
+
+ eapply_user
+}
+
+src_configure() {
+ econf \
+ --with-bindir="${EPREFIX}"/usr/bin \
+ --with-cachedir="${EPREFIX}"/var/lib/${PN} \
+ --with-confdir="${EPREFIX}"/etc/${PN} \
+ --with-datadir="${EPREFIX}"/var/lib/${PN} \
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --with-logdir="${EPREFIX}"/var/log/${PN} \
+ --with-modulesdir="${EPREFIX}"/usr/"$(get_libdir)"/${PN}/modules \
+ --with-pidfile="${EPREFIX}"/run/${PN}/ircd.pid \
+ --with-tmpdir="${EPREFIX}"/var/lib/${PN}/tmp \
+ --with-nick-history=2000 \
+ --with-sendq=3000000 \
+ --with-permissions=0600 \
+ --with-fd-setsize=1024 \
+ --with-system-cares \
+ --with-system-pcre2 \
+ --with-system-tre \
+ --enable-dynamic-linking \
+ $(use_enable curl libcurl "${EPREFIX}"/usr) \
+ $(use_enable prefixaq) \
+ $(use_enable ssl ssl "${EPREFIX}"/usr) \
+ $(use_with showlistmodes) \
+ $(use_with topicisnuhost) \
+ $(use_with shunnotices) \
+ $(use_with !operoverride no-operoverride) \
+ $(use_with operoverride-verify) \
+ $(use_with !usermod disableusermod) \
+ $(use_with !extban-stacking disable-extendedban-stacking)
+}
+
+src_install() {
+ keepdir /var/log/${PN}
+ keepdir /var/lib/${PN}/tmp
+
+ newbin src/ircd ${PN}
+
+ (
+ cd src/modules || die
+ for subdir in $(find . -type d -print); do
+ if [[ -n $(shopt -s nullglob; echo ${subdir}/*.so) ]]; then
+ exeinto /usr/$(get_libdir)/${PN}/modules/"${subdir}"
+ doexe "${subdir}"/*.so
+ fi
+ done
+ )
+
+ insinto /etc/${PN}
+ # Purposefully omitting the examples/ and ssl/ subdirectories. ssl
+ # is redundant with app-misc/ca-certificates and examples will all
+ # be in docs anyway.
+ doins -r doc/conf/{aliases,help}
+ doins doc/conf/*.conf
+ newins doc/conf/examples/example.conf ${PN}.conf
+ use ssl && keepdir /etc/${PN}/ssl
+
+ dodoc \
+ doc/{Changes.old,Changes.older,RELEASE-NOTES} \
+ doc/{Donation,translations.txt}
+
+ newinitd "${FILESDIR}"/${PN}.initd-r1 ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd-r2 ${PN}
+
+ # config should be read-only
+ fperms -R 0640 /etc/${PN}
+ fperms 0750 /etc/${PN}{,/aliases,/help}
+ use ssl && fperms 0750 /etc/${PN}/ssl
+ # state is editable but not owned by unrealircd directly
+ fperms 0770 /var/log/${PN}
+ fperms 0770 /var/lib/${PN}{,/tmp}
+ fowners -R root:unrealircd /{etc,var/{lib,log}}/${PN}
+}
+
+pkg_preinst() {
+ # Must pre-create directories; otherwise their permissions are lost
+ # on installation.
+
+ # Usage: _unrealircd_dir_permissions <user> <group> <mode> <dir>[, <dir>…]
+ #
+ # Ensure that directories are created with the correct permissions
+ # before portage tries to merge them to the filesystem because,
+ # otherwise, those directories are installed world-readable.
+ #
+ # If this is a first-time install, create those directories with
+ # correct permissions before installing. Otherwise, update
+ # permissions—but only if we are replacing an unrealircd ebuild at
+ # least as old as net-irc/unrealircd-3.2.10. Portage handles normal
+ # file permissions correctly, so no need for recursive
+ # chmoding/chowning.
+ _unrealircd_dir_permissions() {
+ local user=${1} group=${2} mode=${3} dir v
+ shift 3
+ while dir=${1} && shift; do
+ if [[ ! -d "${EROOT}${dir}" ]]; then
+ ebegin "Creating ${EROOT}${dir} with correct permissions"
+ install -d -m "${mode}" -o "${user}" -g "${group}" "${EROOT}${dir}" || die
+ eend ${?}
+ elif ! [[ ${REPLACING_VERSIONS} ]] || for v in ${REPLACING_VERSIONS}; do
+ # If 3.2.10 ≤ ${REPLACING_VERSIONS}, then we update
+ # existing permissions.
+ version_is_at_least "${v}" 3.2.10 && break
+ done; then
+ ebegin "Correcting permissions of ${EROOT}${dir} left by ${CATEGORY}/${PN}-${v}"
+ chmod "${mode}" "${EROOT}${dir}" \
+ && chown ${user}:${group} "${EROOT}${dir}" \
+ || die "Unable to correct permissions of ${EROOT}${dir}"
+ eend ${?}
+ fi
+ done
+ }
+
+ # unrealircd only needs to be able to read files in /etc/unrealircd.
+ _unrealircd_dir_permissions root unrealircd 0750 etc/${PN}{,/aliases}
+
+ # unrealircd needs to be able to create files in /var/lib/unrealircd
+ # and /var/log/unrealircd.
+ _unrealircd_dir_permissions root unrealircd 0770 var/{lib,log}/${PN}
+}
+
+pkg_postinst() {
+ # Move docert call from src_install() to install_cert in pkg_postinst for
+ # bug #201682
+ if use ssl ; then
+ if [[ ! -f "${EROOT}"etc/${PN}/ssl/server.cert.key ]]; then
+ if [[ -f "${EROOT}"etc/${PN}/server.cert.key ]]; then
+ ewarn "The location ${PN} looks for SSL certificates has changed"
+ ewarn "from ${EROOT}etc/${PN} to ${EROOT}etc/${PN}/ssl."
+ ewarn "Please move your existing certificates."
+ else
+ (
+ umask 0037
+ install_cert /etc/${PN}/ssl/server.cert
+ chown unrealircd "${EROOT}"etc/${PN}/ssl/server.cert.*
+ ln -snf server.cert.key "${EROOT}"etc/${PN}/ssl/server.key.pem
+ )
+ fi
+ fi
+ fi
+
+ local unrealircd_conf="${EROOT}"etc/${PN}/${PN}.conf
+ # Fix up the default cloak keys.
+ if grep -qe '"and another one";$' "${unrealircd_conf}" && grep -qe '"aoAr1HnR6gl3sJ7hVz4Zb7x4YwpW";$' "${unrealircd_conf}"; then
+ ebegin "Generating cloak-keys"
+ local keys=(
+ $(${PN} -k 2>&1 | tail -n 3)
+ )
+ [[ -n ${keys[0]} || -n ${keys[1]} || -n ${keys[2]} ]]
+ eend $?
+
+ ebegin "Substituting cloak-keys into ${unrealircd_conf}"
+ sed -i \
+ -e '/cloak-keys/ {
+n
+s/"aoAr1HnR6gl3sJ7hVz4Zb7x4YwpW";/"'"${keys[0]}"'";/
+n
+s/"and another one";/"'"${keys[1]}"'";/
+n
+s/"and another one";/"'"${keys[2]}"'";/
+}' \
+ "${unrealircd_conf}"
+ eend $?
+ fi
+
+ elog "UnrealIRCd will not run until you've set up /etc/unrealircd/unrealircd.conf"
+ elog
+ elog "You can also configure ${PN} start at boot with rc-update(1)."
+ elog "Note that it is recommended to run unrealircd as an"
+ elog "unprivileged user (the provided init.d script does this"
+ elog "for you). Running as root will break file permissions."
+}