summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-03-15 16:36:58 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-03-15 16:40:57 -0400
commit40d957e0baec355f907d83bc1aa93c7d2e06f115 (patch)
treee701361a6e1fb8434c864dbc17bf8cef88954968 /net-libs/axtls
parentsys-firmware/b43legacy-firmware: license says unmodified (diff)
downloadgentoo-40d957e0baec355f907d83bc1aa93c7d2e06f115.tar.gz
gentoo-40d957e0baec355f907d83bc1aa93c7d2e06f115.tar.bz2
gentoo-40d957e0baec355f907d83bc1aa93c7d2e06f115.zip
net-libs/axtls: version bump to 2.1.5
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/axtls')
-rw-r--r--net-libs/axtls/Manifest1
-rw-r--r--net-libs/axtls/axtls-2.1.5.ebuild178
2 files changed, 179 insertions, 0 deletions
diff --git a/net-libs/axtls/Manifest b/net-libs/axtls/Manifest
index 4de2c6e83b58..54c033cd5a87 100644
--- a/net-libs/axtls/Manifest
+++ b/net-libs/axtls/Manifest
@@ -3,3 +3,4 @@ DIST axTLS-2.1.1.tar.gz 1305982 BLAKE2B 37f6a233139ed290fd96787644eb9c40de57f4dd
DIST axTLS-2.1.2.tar.gz 1317506 BLAKE2B e331ac1028fa59821e8213c30349839d324e62a24e3cb602050f87dab4ce044964bf04aa5dda1b533fc623ed300bb3a8987c4f5faa7e06c7b5b13e62a46c9d2d SHA512 29e915c0b8549cf93f0664525c84281dd64159dcb3703badec382d203d0209b4f97d7cb875c710610da8e50a7e28d2b94ac161d1fd5fb625d492b15869333ada
DIST axTLS-2.1.3.tar.gz 1316776 BLAKE2B f60502d34a9d23ac772e1bbe05dc9350ab2385fb3c42480117120923647f122ef7a955289b656b8a70b3ac9817b1bcf947f541739b8d01ebe1eb4340f8d9cf38 SHA512 aa116b671bf0fa059cb77f9e5c0307c48ab476b7ce7017f1d4b2e6362d9d527e534908cb30ec3667eec8c49566f950de3ae4ec0adf5b603fb4efb571eaffc596
DIST axTLS-2.1.4.tar.gz 1316768 BLAKE2B 3ff302c59313ee80d18a0d5390c591e6259625e62707cc0c7c677add1f7fddffa5b4dc46860ee18dd96fcc227b3cac1179ab290f8af50ac91fe2841fff977cd4 SHA512 ce301719a12f5b836e3c67a169119d2836382b7b97d39f4010b8b8a644a6751b9f948a6c91f8dc6c39d19f5723311af7aca8958f9052e72cb38a9907247af3e6
+DIST axTLS-2.1.5.tar.gz 1318286 BLAKE2B a4f7cb551f3569fbc9a3a7e0e8faa929a5310fdb412283487fedd4a58e36a65529ebd9aec859027ca6df8e69db85b9f908b56f8d37284548b3984da10774ca3d SHA512 d208b174c31a144a779185e77834a34b0fdd15e8cadf4665b8fd76dcb3207955ed687f3d86d1e60f85d108ecccfd900a76e6d045d16a7182001e0b58da09be18
diff --git a/net-libs/axtls/axtls-2.1.5.ebuild b/net-libs/axtls/axtls-2.1.5.ebuild
new file mode 100644
index 000000000000..490ad132093a
--- /dev/null
+++ b/net-libs/axtls/axtls-2.1.5.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib multilib-minimal savedconfig toolchain-funcs user
+
+################################################################################
+# axtls CONFIG MINI-HOWTO
+#
+# Note: axtls is highly configurable and uses mconf, like the linux kernel.
+# You can configure it in a couple of ways:
+#
+# 1) USE="-savedconfig" and set/unset the remaining flags to obtain the features
+# you want, and possibly a lot more.
+#
+# 2) You can create your own configuration file by doing
+#
+# FEATURES="keepwork" USE="savedconfig -*" emerge axtls
+# cd /var/tmp/portage/net-libs/axtls*/work/axTLS
+# make menuconfig
+#
+# Now configure axtls as you want. Finally save your config file:
+#
+# cp config/.config /etc/portage/savedconfig/net-libs/axtls-${PV}
+#
+# where ${PV} is the current version. You can then run emerge again with
+# your configuration by doing
+#
+# USE="savedconfig" emerge axtls
+#
+################################################################################
+
+MY_PN=${PN/tls/TLS}
+
+DESCRIPTION="Embedded client/server TLSv1 SSL library and small HTTP(S) server"
+HOMEPAGE="http://axtls.sourceforge.net/"
+SRC_URI="mirror://sourceforge/axtls/${MY_PN}-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-code"
+
+LICENSE="BSD GPL-2"
+SLOT="0/1"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="httpd cgi-lua cgi-php static static-libs doc"
+
+# TODO: add ipv6, and c#, java, lua, perl bindings
+# Currently these all have some issue
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND="
+ httpd? (
+ cgi-lua? ( dev-lang/lua )
+ cgi-php? ( dev-lang/php[cgi] )
+ )"
+
+#Note1: static, cgi-* makes no sense if httpd is not given
+REQUIRED_USE="
+ static? ( httpd )
+ cgi-lua? ( httpd )
+ cgi-php? ( httpd )"
+
+AXTLS_GROUP="axtls"
+AXTLS_USER="axtls"
+
+pkg_setup() {
+ use httpd && {
+ ebegin "Creating axtls user and group"
+ enewgroup ${AXTLS_GROUP}
+ enewuser ${AXTLS_USER} -1 -1 -1 ${AXTLS_GROUP}
+ }
+}
+
+src_prepare() {
+ tc-export AR CC
+
+ eapply "${FILESDIR}/explicit-libdir-r1.patch"
+
+ #We want CONFIG_DEBUG to avoid stripping
+ #but not for debugging info
+ sed -i -e 's: -g::' config/Rules.mak || die
+ sed -i -e 's: -g::' config/makefile.conf || die
+
+ eapply_user
+
+ multilib_copy_sources
+}
+
+use_flag_config() {
+ cp "${FILESDIR}"/config config/.config || die
+
+ #Respect CFLAGS/LDFLAGS
+ sed -i -e "s:^CONFIG_EXTRA_CFLAGS_OPTIONS.*$:CONFIG_EXTRA_CFLAGS_OPTIONS=\"${CFLAGS}\":" \
+ config/.config || die
+ sed -i -e "s:^CONFIG_EXTRA_LDFLAGS_OPTIONS.*$:CONFIG_EXTRA_LDFLAGS_OPTIONS=\"${LDLAGS}\":" \
+ config/.config || die
+
+ #The logic is that the default config file enables everything and we disable
+ #here with sed unless a USE flags says to keep it
+ if use httpd; then
+ if ! use static; then
+ sed -i -e 's:^CONFIG_HTTP_STATIC_BUILD:# CONFIG_HTTP_STATIC_BUILD:' \
+ config/.config || die
+ fi
+ if ! use cgi-php && ! use cgi-lua; then
+ sed -i -e 's:^CONFIG_HTTP_HAS_CGI:# CONFIG_HTTP_HAS_CGI:' \
+ config/.config || die
+ fi
+ if ! use cgi-php; then
+ sed -i -e 's:,.php::' config/.config || die
+ fi
+ if ! use cgi-lua; then
+ sed -i -e 's:\.lua,::' \
+ -e 's:lua:php:' \
+ -e 's:^CONFIG_HTTP_ENABLE_LUA:# CONFIG_HTTP_ENABLE_LUA:' \
+ config/.config || die
+ fi
+ else
+ sed -i -e 's:^CONFIG_AXHTTPD:# CONFIG_AXHTTPD:' \
+ config/.config || die
+ fi
+
+ yes "n" | emake -j1 oldconfig > /dev/null || die
+}
+
+multilib_src_configure() {
+ #Per-ABI substitutions.
+ sed -i -e 's:^LIBDIR.*/lib:LIBDIR = $(PREFIX)/'"$(get_libdir):" \
+ Makefile || die
+
+ #Use CC as the host compiler for mconf
+ sed -i -e "s:^HOSTCC.*:HOSTCC=${CC}:" \
+ config/Rules.mak || die
+
+ if use savedconfig; then
+ restore_config config/.config
+ if [[ -f config/.config ]]; then
+ ewarn "Using saved config, all other USE flags ignored"
+ else
+ ewarn "No saved config, seeding with the default"
+ cp "${FILESDIR}"/config config/.config || die
+ fi
+ yes "" | emake -j1 oldconfig > /dev/null || die
+ else
+ use_flag_config
+ fi
+}
+
+multilib_src_install() {
+ if multilib_is_native_abi && use savedconfig; then
+ save_config config/.config
+ fi
+
+ emake PREFIX="${ED}/usr" install
+
+ if ! use static-libs; then
+ rm -f "${ED}"/usr/$(get_libdir)/libaxtls.a || die
+ fi
+
+ # The build system needs to install before it builds docs
+ if multilib_is_native_abi && use doc; then
+ emake docs
+ dodoc -r docsrc/html
+ fi
+}
+
+multilib_src_install_all() {
+ if [[ -f "${ED}"/usr/bin/htpasswd ]]; then
+ mv "${ED}"/usr/bin/{,ax}htpasswd || die
+ fi
+
+ if use httpd; then
+ newinitd "${FILESDIR}"/axhttpd.initd axhttpd
+ newconfd "${FILESDIR}"/axhttpd.confd axhttpd
+ fi
+
+ docompress -x /usr/share/doc/${PF}/README
+ dodoc README
+}