summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-21 22:26:59 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-21 22:56:36 +0200
commitb5d0c055a64281141eb48ad2c5a200375a04031d (patch)
treec0a9db1b1c9c7e900460aac97f5f3da67440dbe5 /net-libs/dleyna-core
parentnet-misc/rygel: bump to 0.38.3 (diff)
downloadgentoo-b5d0c055a64281141eb48ad2c5a200375a04031d.tar.gz
gentoo-b5d0c055a64281141eb48ad2c5a200375a04031d.tar.bz2
gentoo-b5d0c055a64281141eb48ad2c5a200375a04031d.zip
net-libs/dleyna-core: bump to 0.6.0 and use gupnp-1.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/dleyna-core')
-rw-r--r--net-libs/dleyna-core/Manifest1
-rw-r--r--net-libs/dleyna-core/dleyna-core-0.6.0.ebuild38
-rw-r--r--net-libs/dleyna-core/files/0.6.0-gupnp-1.2.patch73
3 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/dleyna-core/Manifest b/net-libs/dleyna-core/Manifest
index 50b5b412ca1f..ce6201af5e92 100644
--- a/net-libs/dleyna-core/Manifest
+++ b/net-libs/dleyna-core/Manifest
@@ -1 +1,2 @@
DIST dleyna-core-0.5.0.tar.gz 337307 BLAKE2B fc2b342d1cfd3b132f10bea55b386f7fc0fb31cb541272c5cc002c985b2830c9ac425c497feeb62ebc2bdad76d91f9123408dbd00b24080d1a3b1902e8743727 SHA512 8611ae61482dcb0ca55513ed4ce7cae9372f88d710033e5abbaeb3c06533a7b2ac143757776bf9ced0dd3f0149ee9f2e42e90fac3ecbbeb42f38d13aeae7849f
+DIST dleyna-core-0.6.0.tar.gz 30821 BLAKE2B f97ef825ef28efd58877487074c0146f8c8425b000537a2281ab44465829030ba9b837f95ad16b56044837a3e571a0ce54a8126ddafc2dda551dbf1d8b11a79e SHA512 cda3f3ee2bea860b06447ab79d8ca62a29c8d26215774c44adb05e57316b95acd4df6ee4ecdd731574b6da5b3aef1c08977a649288004a62a88af38a83157b57
diff --git a/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild b/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild
new file mode 100644
index 000000000000..d60cf90fb902
--- /dev/null
+++ b/net-libs/dleyna-core/dleyna-core-0.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="utility library for higher level dLeyna libraries"
+HOMEPAGE="https://01.org/dleyna/"
+SRC_URI="https://01.org/sites/default/files/downloads/dleyna/${P}.tar_3.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="1.0/4"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=net-libs/gupnp-1.2.0:0=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gupnp-1.2.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}
diff --git a/net-libs/dleyna-core/files/0.6.0-gupnp-1.2.patch b/net-libs/dleyna-core/files/0.6.0-gupnp-1.2.patch
new file mode 100644
index 000000000000..71eef9f37b37
--- /dev/null
+++ b/net-libs/dleyna-core/files/0.6.0-gupnp-1.2.patch
@@ -0,0 +1,73 @@
+From 41b2e56f67b6fc9c8c256b86957d281644b9b846 Mon Sep 17 00:00:00 2001
+From: Jan Tojnar <jtojnar@gmail.com>
+Date: Sat, 16 Mar 2019 05:39:38 +0100
+Subject: [PATCH] Port to gupnp-1.2
+
+The latest version of gupnp breaks backwards compatibility. Fortunately,
+there are not many calls to gupnp functions in core, so we just needed
+to bump the dependencies.
+
+There is one deprecated gupnp_service_proxy_cancel_action call but
+I am not sure how to change it without breaking Dleyna API.
+Let's leave it for now.
+---
+ configure.ac | 2 +-
+ dleyna-core-1.0.pc.in | 2 +-
+ libdleyna/core/main-loop.c | 4 ----
+ libdleyna/core/service-task.c | 1 +
+ 4 files changed, 3 insertions(+), 6 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9a96c84..9f769e2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -39,7 +39,7 @@ PKG_PROG_PKG_CONFIG(0.16)
+ PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.28])
+ PKG_CHECK_MODULES([GIO], [gio-2.0 >= 2.28])
+ PKG_CHECK_MODULES([GMODULE], [gmodule-2.0 >= 2.28])
+-PKG_CHECK_MODULES([GUPNP], [gupnp-1.0 >= 0.20.5])
++PKG_CHECK_MODULES([GUPNP], [gupnp-1.2 >= 1.2.0])
+
+ # Checks for header files.
+ AC_CHECK_HEADERS([stdlib.h string.h syslog.h])
+diff --git a/dleyna-core-1.0.pc.in b/dleyna-core-1.0.pc.in
+index 966a8e1..52b718e 100644
+--- a/dleyna-core-1.0.pc.in
++++ b/dleyna-core-1.0.pc.in
+@@ -8,5 +8,5 @@ Name: @PACKAGE@
+ Description: UPnP & DLNA core library
+ Libs: -L${libdir} -ldleyna-core-1.0
+ Cflags: -I${includedir}/dleyna-1.0
+-Requires: glib-2.0 gio-2.0 gmodule-2.0 gupnp-1.0
++Requires: glib-2.0 gio-2.0 gmodule-2.0 gupnp-1.2
+ Version: @VERSION@
+diff --git a/libdleyna/core/main-loop.c b/libdleyna/core/main-loop.c
+index 3642a5b..9716b06 100644
+--- a/libdleyna/core/main-loop.c
++++ b/libdleyna/core/main-loop.c
+@@ -128,10 +128,6 @@ int dleyna_main_loop_start(const char *server,
+ {
+ int retval = 1;
+
+-#if !GLIB_CHECK_VERSION(2, 35, 0)
+- g_type_init();
+-#endif
+-
+ dleyna_log_init(server, control_point->get_version());
+
+ if (!prv_context_init(server, control_point))
+diff --git a/libdleyna/core/service-task.c b/libdleyna/core/service-task.c
+index e0ca2df..fb113c3 100644
+--- a/libdleyna/core/service-task.c
++++ b/libdleyna/core/service-task.c
+@@ -103,6 +103,7 @@ void dleyna_service_task_cancel_cb(dleyna_task_atom_t *atom, gpointer user_data)
+
+ if (task->p_action) {
+ if (task->proxy)
++ // TODO: switch to GCancellable
+ gupnp_service_proxy_cancel_action(task->proxy,
+ task->p_action);
+ task->p_action = NULL;
+--
+2.20.1
+