summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-02-23 14:21:25 +0200
committerMart Raudsepp <leio@gentoo.org>2020-02-23 14:24:31 +0200
commit9efb97045fd98267a26fdc7bda76c0cdfd134714 (patch)
tree5fe298668c48f66f3ab787c2fdd4afd99d651493 /net-libs/glib-networking
parentdev-libs/glib: bump to 2.62.5 (diff)
downloadgentoo-9efb97045fd98267a26fdc7bda76c0cdfd134714.tar.gz
gentoo-9efb97045fd98267a26fdc7bda76c0cdfd134714.tar.bz2
gentoo-9efb97045fd98267a26fdc7bda76c0cdfd134714.zip
net-libs/glib-networking: bump to 2.62.3
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/glib-networking')
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.62.3.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 7e2283e2162e..12fe39ecc38e 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,2 +1,3 @@
DIST glib-networking-2.60.3.tar.xz 185132 BLAKE2B 8bbe2b8afb779bac99bd554c384bdbf9e197e9b71dc6fe213cdd4352d95ce19d1c9786747ba5c721fc35bdda3e1325e9620c1ef15ca1fa1e294aad9ab3f9a4bc SHA512 06a50aee1a563f5e992549e963d3980b02c9068976a244ce4a84eb0aca064b2ab7e8d50e3ef26dbd0d8d5edbddc82c5ce83d4a93bfaa0822b79465f0d3b8609f
DIST glib-networking-2.60.4.tar.xz 185628 BLAKE2B b10fecb88f09c4c33718a923f6ae5790baada485b4dd3637b0ae9bf5f831b74ac4b87fc398eed4c4a88b7069e4c5bc9a58c04ccbffc056648baa58b43d4489a3 SHA512 db1019c0fc712c0702679146bdd9490101cec63796792a33c7fc7fe26a85d343cfb11f718601a8d3bd91167505bbe60333cc01999a0496826c31681bb8dd4032
+DIST glib-networking-2.62.3.tar.xz 183996 BLAKE2B 3841a355fe485f30970ab571fbe7ae73c8351cdcdad5021809fcac4663bca31b309a0921d07b2551c428ac154da2290e377da0299e66b2b099dfb556f387d18b SHA512 6bcf7584a4d97745e980598eb9182ba2e416471455d9c3debc4cbaea07250e395f6d7001af544ce0114a26d726e71e9b420d9756508cda09499016e89f4a6da1
diff --git a/net-libs/glib-networking/glib-networking-2.62.3.ebuild b/net-libs/glib-networking/glib-networking-2.62.3.ebuild
new file mode 100644
index 000000000000..8862fff92c3c
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.62.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson multilib-minimal xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.60.0:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.11-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.4.6:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ test? ( sys-apps/dbus )
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Dstatic_modules=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}