summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-10-20 23:03:06 +0300
committerMart Raudsepp <leio@gentoo.org>2019-10-20 23:57:01 +0300
commit6cb4bb7bf1aefdda662747d7939da81123c782d1 (patch)
treefd5d3f1a9434deac9ff9e96c03ac69bb1548372f /net-libs/gnome-online-accounts/gnome-online-accounts-3.32.1.ebuild
parentsys-devel/gcc: 7.4.0: drop unappliable 23_all-pgo.patch (diff)
downloadgentoo-6cb4bb7bf1aefdda662747d7939da81123c782d1.tar.gz
gentoo-6cb4bb7bf1aefdda662747d7939da81123c782d1.tar.bz2
gentoo-6cb4bb7bf1aefdda662747d7939da81123c782d1.zip
net-libs/gnome-online-accounts: bump to 3.32.1
Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/gnome-online-accounts/gnome-online-accounts-3.32.1.ebuild')
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.32.1.ebuild82
1 files changed, 82 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.32.1.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.32.1.ebuild
new file mode 100644
index 000000000000..d35a99d2acd9
--- /dev/null
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.32.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="GNOME framework for accessing online accounts"
+HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
+
+LICENSE="LGPL-2+"
+SLOT="0/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug gnome +introspection kerberos +vala"
+REQUIRED_USE="vala? ( introspection )"
+
+# pango used in goaeditablelabel
+# libsoup used in goaoauthprovider
+# goa kerberos provider is incompatible with app-crypt/heimdal, see
+# https://bugzilla.gnome.org/show_bug.cgi?id=692250
+# json-glib-0.16 needed for bug #485092
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=app-crypt/libsecret-0.5
+ >=dev-libs/json-glib-0.16
+ dev-libs/libxml2:2
+ >=net-libs/libsoup-2.42:2.4
+ net-libs/rest:0.7
+ >=net-libs/webkit-gtk-2.12.0:4
+ >=x11-libs/gtk+-3.19.12:3
+ x11-libs/pango
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
+ kerberos? (
+ app-crypt/gcr:0=[gtk]
+ app-crypt/mit-krb5 )
+"
+# telepathy? ( net-libs/telepathy-glib )
+# goa-daemon can launch gnome-control-center
+PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
+
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.3
+ >=dev-util/gdbus-codegen-2.30.0
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # TODO: Give users a way to set the G/FB/Windows Live secrets
+ gnome2_src_configure \
+ --disable-static \
+ --enable-backend \
+ --enable-documentation \
+ --enable-exchange \
+ --enable-facebook \
+ --enable-flickr \
+ --enable-foursquare \
+ --enable-imap-smtp \
+ --enable-lastfm \
+ --enable-media-server \
+ --enable-owncloud \
+ --enable-pocket \
+ --enable-windows-live \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable kerberos) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}