summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-04 06:45:12 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-04 06:45:37 -0400
commitc30801005e5c7ab2516b72dde5d792ec092d0a6e (patch)
tree3add7425e12ad53156c6b9418c70e7c323e3829f /net-libs/gupnp-av
parentdev-java/jmh-core: Stabilize 1.35 amd64, #849659 (diff)
downloadgentoo-c30801005e5c7ab2516b72dde5d792ec092d0a6e.tar.gz
gentoo-c30801005e5c7ab2516b72dde5d792ec092d0a6e.tar.bz2
gentoo-c30801005e5c7ab2516b72dde5d792ec092d0a6e.zip
net-libs/gupnp-av: Version bump to 0.14.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/gupnp-av')
-rw-r--r--net-libs/gupnp-av/Manifest1
-rw-r--r--net-libs/gupnp-av/gupnp-av-0.14.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/gupnp-av/Manifest b/net-libs/gupnp-av/Manifest
index dfb79ffb1988..affcedc7cbad 100644
--- a/net-libs/gupnp-av/Manifest
+++ b/net-libs/gupnp-av/Manifest
@@ -1 +1,2 @@
DIST gupnp-av-0.14.0.tar.xz 93128 BLAKE2B d66ba820aabf82be37a8c19a64adbacc863b495cb6a68849ee236cbe6956cc94fc992a3d4f351d165efaa8257ece2f3173dd845d2a9313bc9ff1a97a178d9632 SHA512 b357b5413d3e01e4ecaf9dbdf5f5f15555506aed662154d03c6232f0c82c4a49543deddf34350a204d467c1a33fed04e406500fd51d6e412d32ac909e974e041
+DIST gupnp-av-0.14.1.tar.xz 93484 BLAKE2B 5e4c070bc7f0dd1a1b67f58fb178ee575df5f9f3920c8c40f8975ac79c61f707df39a243d4783ff79f691dd42553c3a6eb89715be79bb7683910785afdd83b19 SHA512 b17b38c32fe068b0b74a7ee357be5f3a0df3320fd04338b5f6b04231c601d6cc57d2770c6e6ca42ded5e1be28a6b2746d16417eb322889ffe6a975ec58205655
diff --git a/net-libs/gupnp-av/gupnp-av-0.14.1.ebuild b/net-libs/gupnp-av/gupnp-av-0.14.1.ebuild
new file mode 100644
index 000000000000..4c2317e33e7a
--- /dev/null
+++ b/net-libs/gupnp-av/gupnp-av-0.14.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson vala
+
+DESCRIPTION="Utility library aiming to ease the handling UPnP A/V profiles"
+HOMEPAGE="https://wiki.gnome.org/Projects/GUPnP https://gitlab.gnome.org/GNOME/gupnp-av"
+
+LICENSE="LGPL-2"
+SLOT="0/3" # subslot: soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.58:2
+ >=net-libs/libsoup-2.28.2:2.4[introspection?]
+ dev-libs/libxml2
+ introspection? ( >=dev-libs/gobject-introspection-1.36:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc )
+ introspection? ( $(vala_depend) )
+"
+
+src_prepare() {
+ use introspection && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_use introspection vapi)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}