summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-04-15 21:19:39 +0200
committerJeroen Roovers <jer@gentoo.org>2018-04-15 21:19:39 +0200
commit0b05a57503d8991c1f6cc9d7d312f5b1591a021f (patch)
tree536bdde1f8632ad373d1de9fa147af44e289f479 /net-libs/http-parser
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-0b05a57503d8991c1f6cc9d7d312f5b1591a021f.tar.gz
gentoo-0b05a57503d8991c1f6cc9d7d312f5b1591a021f.tar.bz2
gentoo-0b05a57503d8991c1f6cc9d7d312f5b1591a021f.zip
net-libs/http-parser: Add live ebuild.
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/http-parser-99999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/http-parser/http-parser-99999.ebuild b/net-libs/http-parser/http-parser-99999.ebuild
new file mode 100644
index 000000000000..06a3f2fa0dca
--- /dev/null
+++ b/net-libs/http-parser/http-parser-99999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit git-r3 toolchain-funcs multilib-minimal
+
+DESCRIPTION="HTTP request/response parser for C"
+HOMEPAGE="https://github.com/nodejs/http-parser"
+EGIT_REPO_URI="https://github.com/nodejs/http-parser/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+src_prepare() {
+ default
+ tc-export CC AR
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
+ use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
+}
+
+multilib_src_test() {
+ emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
+ use static-libs && dolib.a libhttp_parser.a
+}