summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-03-07 09:07:34 +0100
committerFabian Groffen <grobian@gentoo.org>2017-03-07 09:08:16 +0100
commitebfa98e3e9c35aea2cc51204ddbf63710a81b783 (patch)
treed0f5659c6a7fd85c0a01ed7d7aa9dd9af3f4abe3 /net-libs/http-parser
parentnet-analyzer/symon: Version bump. (diff)
downloadgentoo-ebfa98e3e9c35aea2cc51204ddbf63710a81b783.tar.gz
gentoo-ebfa98e3e9c35aea2cc51204ddbf63710a81b783.tar.bz2
gentoo-ebfa98e3e9c35aea2cc51204ddbf63710a81b783.zip
net-libs/http-parser: add patch to fix install_name on Darwin, bug #546098
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-libs/http-parser')
-rw-r--r--net-libs/http-parser/files/http-parser-2.6.2-darwin.patch16
-rw-r--r--net-libs/http-parser/http-parser-2.6.2.ebuild3
2 files changed, 18 insertions, 1 deletions
diff --git a/net-libs/http-parser/files/http-parser-2.6.2-darwin.patch b/net-libs/http-parser/files/http-parser-2.6.2-darwin.patch
new file mode 100644
index 000000000000..b04b4a32bb01
--- /dev/null
+++ b/net-libs/http-parser/files/http-parser-2.6.2-darwin.patch
@@ -0,0 +1,16 @@
+Makefile: set install_name on Darwin
+
+https://bugs.gentoo.org/show_bug.cgi?id=546098
+https://github.com/nodejs/http-parser/issues/356
+
+--- http-parser-2.6.2/Makefile
++++ http-parser-2.6.2/Makefile
+@@ -62,6 +62,8 @@
+ ifneq (darwin,$(PLATFORM))
+ # TODO(bnoordhuis) The native SunOS linker expects -h rather than -soname...
+ LDFLAGS_LIB += -Wl,-soname=$(SONAME)
++else
++LDFLAGS_LIB += -Wl,-install_name,$(LIBDIR)/$(SONAME)
+ endif
+
+ test: test_g test_fast
diff --git a/net-libs/http-parser/http-parser-2.6.2.ebuild b/net-libs/http-parser/http-parser-2.6.2.ebuild
index 62d9938548be..33986a95474a 100644
--- a/net-libs/http-parser/http-parser-2.6.2.ebuild
+++ b/net-libs/http-parser/http-parser-2.6.2.ebuild
@@ -21,6 +21,7 @@ PATCHES=(
"${FILESDIR}"/0003-makefile-fix-SONAME-symlink-it-should-not-be-a-full-.patch
"${FILESDIR}"/0004-makefile-add-CFLAGS-to-linking-command.patch
"${FILESDIR}"/0005-makefile-fix-install-rule-dependency.patch
+ "${FILESDIR}"/${PN}-2.6.2-darwin.patch
)
src_prepare() {
@@ -30,7 +31,7 @@ src_prepare() {
}
multilib_src_compile() {
- emake CFLAGS_FAST="${CFLAGS}" library
+ emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
}