summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-27 21:01:27 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-28 19:01:56 -0400
commit835f7044580f9efd03b7bf7d1ff732e25177ba37 (patch)
tree882b26306da7caa4a6d31e665429048cd61ab14b /net-libs/iax
parentnet-im/librvp: bump EAPI (diff)
downloadgentoo-835f7044580f9efd03b7bf7d1ff732e25177ba37.tar.gz
gentoo-835f7044580f9efd03b7bf7d1ff732e25177ba37.tar.bz2
gentoo-835f7044580f9efd03b7bf7d1ff732e25177ba37.zip
net-libs/iax: bump EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-libs/iax')
-rw-r--r--net-libs/iax/iax-0.2.2-r1.ebuild14
-rw-r--r--net-libs/iax/iax-0.2.2-r3.ebuild25
2 files changed, 17 insertions, 22 deletions
diff --git a/net-libs/iax/iax-0.2.2-r1.ebuild b/net-libs/iax/iax-0.2.2-r1.ebuild
index 5bdaf96a5ee8..46813b978f01 100644
--- a/net-libs/iax/iax-0.2.2-r1.ebuild
+++ b/net-libs/iax/iax-0.2.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
-HOMEPAGE="http://www.asterisk.org/"
-SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+HOMEPAGE="https://www.asterisk.org/"
+SRC_URI="https://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
@@ -13,6 +13,7 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE="debug snomhack"
src_prepare() {
+ default
if ! use debug; then
sed -i -e "s:-DDEBUG_SUPPORT -DDEBUG_DEFAULT ::" src/Makefile.in \
|| die "sed failed"
@@ -34,8 +35,3 @@ src_configure() {
$(use_enable debug extreme-debug) \
$(use_enable snomhack)
}
-
-src_install () {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
-}
diff --git a/net-libs/iax/iax-0.2.2-r3.ebuild b/net-libs/iax/iax-0.2.2-r3.ebuild
index 8f8fb31fe582..42757477e346 100644
--- a/net-libs/iax/iax-0.2.2-r3.ebuild
+++ b/net-libs/iax/iax-0.2.2-r3.ebuild
@@ -1,23 +1,27 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit autotools eutils
+inherit autotools
DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
-HOMEPAGE="http://www.asterisk.org/"
-SRC_URI="http://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
+HOMEPAGE="https://www.asterisk.org/"
+SRC_URI="https://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug snomhack"
+PATCHES=(
+ "${FILESDIR}/${PV}-debug.patch"
+ "${FILESDIR}/${PV}-memset.patch"
+ "${FILESDIR}/${PV}-sandbox.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${PV}-debug.patch"
- epatch "${FILESDIR}/${PV}-memset.patch"
- epatch "${FILESDIR}/${PV}-sandbox.patch"
+ default
eautoreconf
}
@@ -26,8 +30,3 @@ src_configure() {
$(use_enable debug extreme-debug) \
$(use_enable snomhack)
}
-
-src_install () {
- default
- dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
-}