summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-08-07 23:09:16 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-08-07 23:10:33 +0000
commit51c9c9b82e3b44113d39097189bd4f36cc081fc7 (patch)
treeb931d6e9ef08000d275815b11ca86ca6e616edb4 /net-libs/libbtbb
parentnet-libs/webkit-gtk: security cleanup (diff)
downloadgentoo-51c9c9b82e3b44113d39097189bd4f36cc081fc7.tar.gz
gentoo-51c9c9b82e3b44113d39097189bd4f36cc081fc7.tar.bz2
gentoo-51c9c9b82e3b44113d39097189bd4f36cc081fc7.zip
net-libs/libbtbb: bump
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'net-libs/libbtbb')
-rw-r--r--net-libs/libbtbb/Manifest1
-rw-r--r--net-libs/libbtbb/libbtbb-2018.08.1.ebuild156
2 files changed, 157 insertions, 0 deletions
diff --git a/net-libs/libbtbb/Manifest b/net-libs/libbtbb/Manifest
index faa70bb24b2d..e43288145880 100644
--- a/net-libs/libbtbb/Manifest
+++ b/net-libs/libbtbb/Manifest
@@ -1 +1,2 @@
DIST libbtbb-2017-03-R2.tar.gz 303689 BLAKE2B d36cf5329fb31cd50f64e3a9b625ebca8bf198794073480baa4f64935f4bef183e4c11f0844cd31df943da98c778bdea807fbd91676c23a3a2f830af5e7a185f SHA512 bb7b58a33198fd64fba5f0254cfbb71120c70476d594a7aaf82c77f770d1a6e89b4571f42d3d15c1d93d5246c9145c33ba8724a5ee5ad84e96f748d9f32275b5
+DIST libbtbb-2018-08-R1.tar.gz 310542 BLAKE2B 0ae945c530c476caadfd7786f34eca4d7efd71c2f27a37c7b0242a1d3fba80e985c76a0635a354184aa80039ca8ac11f59778f550cbe9bb7e8a535723396cab0 SHA512 63fa995b51f2246b6f27d8aa1bd7a5c0276414df9d13d432d9a1a7ad78ac06e4c67fe3dcf00cf1634f11d6e999f13633591a3347d4e533fff4f131f8deee922e
diff --git a/net-libs/libbtbb/libbtbb-2018.08.1.ebuild b/net-libs/libbtbb/libbtbb-2018.08.1.ebuild
new file mode 100644
index 000000000000..998113cc4029
--- /dev/null
+++ b/net-libs/libbtbb/libbtbb-2018.08.1.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_OPTIONAL=1
+
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="A library to decode Bluetooth baseband packets"
+HOMEPAGE="http://libbtbb.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/greatscottgadgets/libbtbb.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_PV=${PV/\./-}
+ MY_PV=${MY_PV/./-R}
+ S=${WORKDIR}/${PN}-${MY_PV}
+ SRC_URI="https://github.com/greatscottgadgets/${PN}/archive/${MY_PV}.tar.gz -> ${PN}-${MY_PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+IUSE="extras static-libs wireshark-plugins"
+
+RDEPEND="extras? ( ${PYTHON_DEPS} )
+ wireshark-plugins? (
+ >=net-analyzer/wireshark-1.8.3-r1:=
+ )
+"
+DEPEND="${RDEPEND}
+ wireshark-plugins? ( dev-libs/glib
+ virtual/pkgconfig )"
+
+REQUIRED_USE="extras? ( ${PYTHON_REQUIRED_USE} )"
+
+get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
+
+which_plugins() {
+ if has_version '>=net-analyzer/wireshark-2.2.0'; then
+ plugins=""
+ elif has_version '>=net-analyzer/wireshark-1.12.0'; then
+ plugins="btbb btbredr"
+ elif has_version '<net-analyzer/wireshark-1.12.0'; then
+ plugins="btbb btle btsm"
+ fi
+}
+
+src_prepare(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_prepare
+
+ if use wireshark-plugins; then
+ which_plugins
+ for i in ${plugins}
+ do
+ sed -i 's#column_info#packet#' wireshark/plugins/${i}/cmake/FindWireshark.cmake || die
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_prepare
+ done
+ fi
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ local mycmakeargs=(
+ -DENABLE_PYTHON=$(usex extras)
+ -DBUILD_STATIC_LIB=$(usex static-libs)
+ -DBUILD_ROOT="${ED}"
+ )
+ cmake-utils_src_configure
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/usr/$(get_libdir)/wireshark/plugins/$(get_PV net-analyzer/wireshark)"
+ )
+ cmake-utils_src_configure
+ done
+ fi
+}
+
+src_compile(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_compile
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_compile
+ done
+ fi
+}
+
+src_test(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_test
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_test
+ done
+ fi
+}
+
+src_install(){
+ CMAKE_USE_DIR="${S}"
+ BUILD_DIR="${S}"_build
+ cmake-utils_src_install
+
+ if use wireshark-plugins; then
+ for i in ${plugins}
+ do
+ if has_version '>=net-analyzer/wireshark-2.0'; then
+ CMAKE_USE_DIR="${S}"/wireshark/plugins/${i}
+ else
+ CMAKE_USE_DIR="${S}"/wireshark/plugins-legacy/${i}
+ fi
+ BUILD_DIR="${WORKDIR}"/${i}_build
+ cmake-utils_src_install
+ done
+ fi
+}