summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-03-02 02:00:22 +0100
committerMichael Weber <xmw@gentoo.org>2016-03-02 23:33:56 +0100
commit55f9e19e1293b234981dc25d6b5379058164993c (patch)
treeb291d6cb5b6da779ce3381468718c0b064e035f7 /net-libs/libdom/libdom-0.3.0.ebuild
parentnet-libs/libhubbub: Drop old. (diff)
downloadgentoo-55f9e19e1293b234981dc25d6b5379058164993c.tar.gz
gentoo-55f9e19e1293b234981dc25d6b5379058164993c.tar.bz2
gentoo-55f9e19e1293b234981dc25d6b5379058164993c.zip
net-libs/libdom: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs/libdom/libdom-0.3.0.ebuild')
-rw-r--r--net-libs/libdom/libdom-0.3.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libdom/libdom-0.3.0.ebuild b/net-libs/libdom/libdom-0.3.0.ebuild
new file mode 100644
index 000000000000..81cccdf1d7b3
--- /dev/null
+++ b/net-libs/libdom/libdom-0.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+NETSURF_BUILDSYSTEM=buildsystem-1.5
+inherit netsurf
+
+DESCRIPTION="implementation of the W3C DOM, written in C"
+HOMEPAGE="http://www.netsurf-browser.org/projects/libdom/"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~m68k-mint"
+IUSE="expat test xml"
+
+RDEPEND=">=dev-libs/libparserutils-0.2.1-r1[static-libs?,${MULTILIB_USEDEP}]
+ >=dev-libs/libwapcaplet-0.2.2-r1[static-libs?,${MULTILIB_USEDEP}]
+ >=net-libs/libhubbub-0.3.1-r1[static-libs?,${MULTILIB_USEDEP}]
+ xml? (
+ expat? ( >=dev-libs/expat-2.1.0-r3[static-libs?,${MULTILIB_USEDEP}] )
+ !expat? ( >=dev-libs/libxml2-2.9.1-r4[static-libs?,${MULTILIB_USEDEP}] )
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-perl/XML-XPath
+ dev-perl/libxml-perl
+ dev-perl/Switch )"
+
+REQUIRED_USE="test? ( xml )"
+
+src_configure() {
+ netsurf_src_configure
+
+ netsurf_makeconf+=(
+ WITH_EXPAT_BINDING=$(usex xml $(usex expat yes no) no)
+ WITH_LIBXML_BINDING=$(usex xml $(usex expat no yes) no)
+ )
+}