summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libecap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libecap')
-rw-r--r--net-libs/libecap/Manifest2
-rw-r--r--net-libs/libecap/libecap-0.2.0.ebuild27
-rw-r--r--net-libs/libecap/libecap-1.0.0.ebuild28
-rw-r--r--net-libs/libecap/metadata.xml6
4 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/libecap/Manifest b/net-libs/libecap/Manifest
new file mode 100644
index 000000000000..93104d941c48
--- /dev/null
+++ b/net-libs/libecap/Manifest
@@ -0,0 +1,2 @@
+DIST libecap-0.2.0.tar.gz 337696 SHA256 19e195d60cf67ec3b49fe4d109823d753546b5da115230499ad1a9cb65ca92d2 SHA512 5d39444ec79846b14a7f4292e51bb880befd2cbf581b257d5087517cfae1dce55e4439a90c08e0b8f5b3e8b2431dde8c6fab771c826489024f17625cfc8c777e WHIRLPOOL 2bf13955d9bb8ed598fa30cf004f79fe697a701623ea72556064614f66a1b29992ab5bab5442f50960e712ea938049574f624d39cc5fb0a5881523ece6fa445b
+DIST libecap-1.0.0.tar.gz 343468 SHA256 64c7bb52e04d218903dbc6c7cc4c62cfc22a6db468d1e0f8dac58e0f8620c4be SHA512 7d34b5a9b6843d6b09efc4fa390c7a2d3dda7a2ae5e82d5021295e436ca9afb7c1f70bc6f25a68e4c430fb6e33ee9f602655c9c830fccd46a8f554774813b452 WHIRLPOOL 2f727ac0ef2a7919775df0e8856bc72e8867db3768af27f70d3871f940bce8a6e8aaa3471c913a3c68a7ff04d86c611b1a526b63d448dd054c40d823dd8524f2
diff --git a/net-libs/libecap/libecap-0.2.0.ebuild b/net-libs/libecap/libecap-0.2.0.ebuild
new file mode 100644
index 000000000000..ac6355275541
--- /dev/null
+++ b/net-libs/libecap/libecap-0.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="API for implementing ICAP content analysis and adaptation"
+HOMEPAGE="http://www.e-cap.org/"
+SRC_URI="http://www.measurement-factory.com/tmp/ecap/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0.2"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+RDEPEND="!net-libs/libecap:0"
+
+DOCS=( CREDITS NOTICE README change.log )
+
+src_prepare() {
+ default
+
+ # Respect AR. (bug #457734)
+ tc-export AR
+}
diff --git a/net-libs/libecap/libecap-1.0.0.ebuild b/net-libs/libecap/libecap-1.0.0.ebuild
new file mode 100644
index 000000000000..5c75816a348e
--- /dev/null
+++ b/net-libs/libecap/libecap-1.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="API for implementing ICAP content analysis and adaptation"
+HOMEPAGE="http://www.e-cap.org/"
+SRC_URI="http://www.measurement-factory.com/tmp/ecap/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="1"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="static-libs"
+
+RDEPEND="!net-libs/libecap:0
+ !net-libs/libecap:0.2"
+
+DOCS=( CREDITS NOTICE README change.log )
+
+src_prepare() {
+ default
+
+ # Respect AR. (bug #457734)
+ tc-export AR
+}
diff --git a/net-libs/libecap/metadata.xml b/net-libs/libecap/metadata.xml
new file mode 100644
index 000000000000..20e615c307c4
--- /dev/null
+++ b/net-libs/libecap/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>eras@gentoo.org</email></maintainer>
+<longdescription>eCAP is a software interface that allows a network application, such as an HTTP proxy or an ICAP server, to outsource content analysis and adaptation to a loadable module</longdescription>
+</pkgmetadata>