summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 02:20:40 +0000
committerSam James <sam@gentoo.org>2021-02-27 02:24:59 +0000
commitc1aed01a000f5fae10b98f4cb6020a7d4f4ed877 (patch)
tree2d1e1408b390679a5c52bb92cf854ac5b68e2c52 /net-libs/libecap
parentnet-libs/libecap: port to EAPI 7 (diff)
downloadgentoo-c1aed01a000f5fae10b98f4cb6020a7d4f4ed877.tar.gz
gentoo-c1aed01a000f5fae10b98f4cb6020a7d4f4ed877.tar.bz2
gentoo-c1aed01a000f5fae10b98f4cb6020a7d4f4ed877.zip
net-libs/libecap: bump to 1.0.1
Closes: https://bugs.gentoo.org/731242 Closes: https://bugs.gentoo.org/724912 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libecap')
-rw-r--r--net-libs/libecap/Manifest1
-rw-r--r--net-libs/libecap/libecap-1.0.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libecap/Manifest b/net-libs/libecap/Manifest
index 24b4e78f22ae..d370ec5dbb8a 100644
--- a/net-libs/libecap/Manifest
+++ b/net-libs/libecap/Manifest
@@ -1 +1,2 @@
DIST libecap-1.0.0.tar.gz 343468 BLAKE2B 5a5a12365289daaee8b324016f42b6b56f5bf5b1f7893ae052517c8c20a792a798ebb31f4038c121b1c6eefd9d375562014050572e0285e3a9b91bbfb9989fa8 SHA512 7d34b5a9b6843d6b09efc4fa390c7a2d3dda7a2ae5e82d5021295e436ca9afb7c1f70bc6f25a68e4c430fb6e33ee9f602655c9c830fccd46a8f554774813b452
+DIST libecap-1.0.1.tar.gz 339799 BLAKE2B 6971391d0bde588f6bfb11704d343494eaf81fd1ac5e9c8c6d9f32ae0b03ed41aaf03c41cab1365ffefa8e032b65f72417af395c26d89af69c30d327252246b7 SHA512 0054ad11b3f558d7c623060a69207a1b8e679803cabdf1a2bce4b04335d71c016eec770fc9d2cbf3d0a93502c255cb528305f9f8e6df4e095fcb980667045919
diff --git a/net-libs/libecap/libecap-1.0.1.ebuild b/net-libs/libecap/libecap-1.0.1.ebuild
new file mode 100644
index 000000000000..24efca086b5d
--- /dev/null
+++ b/net-libs/libecap/libecap-1.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="API for implementing ICAP content analysis and adaptation"
+HOMEPAGE="https://www.e-cap.org/"
+SRC_URI="https://www.e-cap.org/archive/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="!net-libs/libecap:0
+ !net-libs/libecap:0.2"
+
+DOCS=( CREDITS NOTICE README change.log )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Horrific autotools failure in generated config.h w/o Bash
+ ac_cv_path_AR="$(tc-getAR)" CONFIG_SHELL="${EPREFIX}/bin/bash" econf --disable-static
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}