summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-10-26 12:50:33 -0400
committerCraig Andrews <candrews@gentoo.org>2018-10-26 14:08:55 -0400
commitfa230af7c9832b53e08d34799acbc5877a912fc5 (patch)
tree970b8f819bdc07a1b71b188b1ba43eeaa695e502 /net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild
parentnet-mail/fetchmail: libressl and OpenSSL 1.1 support, EAPI=7 (diff)
downloadgentoo-fa230af7c9832b53e08d34799acbc5877a912fc5.tar.gz
gentoo-fa230af7c9832b53e08d34799acbc5877a912fc5.tar.bz2
gentoo-fa230af7c9832b53e08d34799acbc5877a912fc5.zip
net-libs/libesmtp: Fix OpenSSL 1.1, EAPI=7 bump
Closes: https://bugs.gentoo.org/624412 Signed-off-by: Craig Andrews <candrews@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild')
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild b/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild
new file mode 100644
index 000000000000..c0d28b116e78
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0.6-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="lib that implements the client side of the SMTP protocol"
+HOMEPAGE="http://brianstafford.info/libesmtp/"
+SRC_URI="http://brianstafford.info/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="debug libressl ntlm ssl static-libs threads"
+
+RDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}"
+DOCS=( AUTHORS ChangeLog NEWS Notes README TODO )
+PATCHES=(
+ "${FILESDIR}/${P}-openssl-1.1-api-compatibility.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ --enable-all \
+ $(use_enable ntlm) \
+ $(use_enable threads pthreads) \
+ $(use_enable debug) \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+ insinto /usr/share/doc/${PF}/xml
+ doins doc/api.xml
+}