summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-12 15:25:59 +0000
committerSam James <sam@gentoo.org>2021-04-12 15:48:33 +0000
commit43ecb1115b82b9d8c57165843da17e8ba3988fda (patch)
tree2c276fe09a1bbf5d53a5d481447fd373816b2526 /net-libs/libesmtp
parentx11-wm/sawfish: add missing x11-libs/* dependencies (diff)
downloadgentoo-43ecb1115b82b9d8c57165843da17e8ba3988fda.tar.gz
gentoo-43ecb1115b82b9d8c57165843da17e8ba3988fda.tar.bz2
gentoo-43ecb1115b82b9d8c57165843da17e8ba3988fda.zip
net-libs/libesmtp: add 1.0.6_p20200824
Includes various security fixes from upstream. Includes Meson port. A lot changed since the last release, so this is preferred to backporting for now. Bug: https://bugs.gentoo.org/782532 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/Manifest1
-rw-r--r--net-libs/libesmtp/libesmtp-1.0.6_p20200824.ebuild37
-rw-r--r--net-libs/libesmtp/libesmtp-9999.ebuild10
3 files changed, 41 insertions, 7 deletions
diff --git a/net-libs/libesmtp/Manifest b/net-libs/libesmtp/Manifest
index 686fe8dc046f..05b0c516e94b 100644
--- a/net-libs/libesmtp/Manifest
+++ b/net-libs/libesmtp/Manifest
@@ -1 +1,2 @@
DIST libesmtp-1.0.6.tar.bz2 365506 BLAKE2B 9ce8c9f210e6c41c95bba55a7aec79c176c4582f5dafc1aba4fbf9adb411b75ab89d400ac7a12b7d5d24ede414cb8e2ca306299a2e156515e611d074142cf5e8 SHA512 c122fc5995b76771cce2db58c9e59597cc3a76d273feb6fc26b869f118e91bdf98a5721ee2d1de8175c376af018b5806b0379bbeba2f5da95108916028fd8dda
+DIST libesmtp-1.0.6_p20200824.tar.gz 156674 BLAKE2B a78dece0cceb252ca7505b5457a9137c6e3f45c544b9774ab683fb1defed6458ed0d94604aa16df540d3e397738fbe00e1c3b3c649f34b73421e494c35cf2fc1 SHA512 bd0868aa8fb10bd81c18d473acaf1ef94ab2278a6619e5d348a59857f459d2d47a22583d7d533a983518ece436853914420b7189c305d9dab5c399bf26f8a5c0
diff --git a/net-libs/libesmtp/libesmtp-1.0.6_p20200824.ebuild b/net-libs/libesmtp/libesmtp-1.0.6_p20200824.ebuild
new file mode 100644
index 000000000000..2cdebea7e57f
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0.6_p20200824.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+COMMIT="c80e46678e1025f3116bdcc75563364744adbe18"
+DESCRIPTION="Lib that implements the client side of the SMTP protocol"
+HOMEPAGE="https://libesmtp.github.io/"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libesmtp/libESMTP.git"
+else
+ #SRC_URI="https://github.com/libesmtp/libESMTP/archive/v${PV/_}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/libesmtp/libESMTP/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/libESMTP-${COMMIT}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+IUSE="ssl static-libs threads"
+
+RDEPEND="ssl? ( >=dev-libs/openssl-1.1.0:0= )"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS docs/{bugreport,ChangeLog,faq}.md NEWS Notes README.md TODO )
+
+src_configure() {
+ local emesonargs=(
+ -Ddefault_library="$(usex static-libs both shared)"
+ $(meson_feature ssl tls)
+ $(meson_feature threads pthreads)
+ )
+ meson_src_configure
+}
diff --git a/net-libs/libesmtp/libesmtp-9999.ebuild b/net-libs/libesmtp/libesmtp-9999.ebuild
index 20a4ae8e7534..52b10fe2282a 100644
--- a/net-libs/libesmtp/libesmtp-9999.ebuild
+++ b/net-libs/libesmtp/libesmtp-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
inherit meson
-DESCRIPTION="lib that implements the client side of the SMTP protocol"
+DESCRIPTION="Lib that implements the client side of the SMTP protocol"
HOMEPAGE="https://libesmtp.github.io/"
if [[ "${PV}" == *9999 ]] ; then
inherit git-r3
@@ -17,13 +17,9 @@ fi
LICENSE="LGPL-2.1 GPL-2"
SLOT="0"
-IUSE="libressl ssl static-libs threads"
+IUSE="ssl static-libs threads"
-RDEPEND="
- ssl? (
- !libressl? ( >=dev-libs/openssl-1.1.0:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
+RDEPEND="ssl? ( >=dev-libs/openssl-1.1.0:0= )"
DEPEND="${RDEPEND}"
DOCS=( AUTHORS docs/{bugreport,ChangeLog,faq}.md NEWS Notes README.md TODO )