summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-10 19:25:54 +0000
committerSam James <sam@gentoo.org>2021-06-10 19:25:54 +0000
commit54b8aef1fbab2e718fe4a352a9b55e95ed26bf54 (patch)
treef79dcdef6a3267839b6cca16350c1ebdee835961 /net-libs/libesmtp
parentdev-lang/mujs: add 1.1.3 (diff)
downloadgentoo-54b8aef1fbab2e718fe4a352a9b55e95ed26bf54.tar.gz
gentoo-54b8aef1fbab2e718fe4a352a9b55e95ed26bf54.tar.bz2
gentoo-54b8aef1fbab2e718fe4a352a9b55e95ed26bf54.zip
net-libs/libesmtp: increment subslot
(See comment in ebuild.) Bug: https://bugs.gentoo.org/782532 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libesmtp')
-rw-r--r--net-libs/libesmtp/files/libesmtp-1.1.0-fix-soname.patch19
-rw-r--r--net-libs/libesmtp/libesmtp-1.1.0-r1.ebuild (renamed from net-libs/libesmtp/libesmtp-1.1.0.ebuild)11
2 files changed, 29 insertions, 1 deletions
diff --git a/net-libs/libesmtp/files/libesmtp-1.1.0-fix-soname.patch b/net-libs/libesmtp/files/libesmtp-1.1.0-fix-soname.patch
new file mode 100644
index 000000000000..52e4386dc0f7
--- /dev/null
+++ b/net-libs/libesmtp/files/libesmtp-1.1.0-fix-soname.patch
@@ -0,0 +1,19 @@
+https://github.com/libesmtp/libESMTP/pull/7
+
+From 4543d5a6848a752d690150b6987ca9c556d793fc Mon Sep 17 00:00:00 2001
+From: "Jeremy T. Bouse" <Jeremy.Bouse@UnderGrid.net>
+Date: Mon, 7 Jun 2021 20:44:37 -0400
+Subject: [PATCH] Update to correct SONAME version
+
+Pass as version to allow Meson to manage SONAME version.
+--- a/meson.build
++++ b/meson.build
+@@ -208,7 +208,7 @@ vflag = '-Wl,--version-script,@0@/@1@'.format(meson.current_source_dir(), mapfil
+
+ lib = library('esmtp', sources,
+ link_args : vflag, link_depends : mapfile,
+- soversion : libesmtp_so_version,
++ version : libesmtp_so_version,
+ dependencies : deps,
+ install : true)
+
diff --git a/net-libs/libesmtp/libesmtp-1.1.0.ebuild b/net-libs/libesmtp/libesmtp-1.1.0-r1.ebuild
index c117af101c94..47acefd3ea35 100644
--- a/net-libs/libesmtp/libesmtp-1.1.0.ebuild
+++ b/net-libs/libesmtp/libesmtp-1.1.0-r1.ebuild
@@ -18,7 +18,12 @@ else
fi
LICENSE="LGPL-2.1 GPL-2"
-SLOT="0/7"
+# 0/7 was a snapshot before 1.1.0
+# The SONAME was fixed just before the 1.1.0 release was made
+# ... but a patch was needed to get it exactly right too
+# so, we're on 0/8 now, even though ABI compatibility actually remained
+# in terms of symbols with the original <1.1.0.
+SLOT="0/8"
IUSE="ssl static-libs threads"
RDEPEND="ssl? ( >=dev-libs/openssl-1.1.0:0= )"
@@ -26,6 +31,10 @@ DEPEND="${RDEPEND}"
DOCS=( docs/{authors,bugreport,ChangeLog,faq,NEWS}.md README.md )
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-soname.patch
+)
+
src_configure() {
local emesonargs=(
-Ddefault_library="$(usex static-libs both shared)"