summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-06-27 21:45:09 +0100
committerMarek Szuba <marecki@gentoo.org>2023-06-27 22:56:21 +0100
commit7d7ca23e474dc5ccbbaedee9741b5511a8334fe2 (patch)
treefccb1310b7f8cc263c4dec1aec6077a6049a3ee2 /net-libs/libhtp
parentdev-libs/protobuf: drop unmaintained 9999 (diff)
downloadgentoo-7d7ca23e474dc5ccbbaedee9741b5511a8334fe2.tar.gz
gentoo-7d7ca23e474dc5ccbbaedee9741b5511a8334fe2.tar.bz2
gentoo-7d7ca23e474dc5ccbbaedee9741b5511a8334fe2.zip
net-libs/libhtp: add 0.5.44
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.44.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index 42547b31cfd5..5838d57a4927 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1 +1,2 @@
DIST libhtp-0.5.43.tar.gz 500631 BLAKE2B 071cadc254b7af55bf410db5689429ca7588005b2f74fbd8468f2d6eeaf00c55ae99e8dd78552a5bf11ace5c8047b28a844db343937827a428b6d8b8d9036d29 SHA512 6d24f4510b0a444895b6dcc601b9e4560fba0da5db591efa58874d2fc8f7c5d6598b6caddc908824ce294e69cdd8ff8bf0d9147f22d395810844cad48f23557d
+DIST libhtp-0.5.44.tar.gz 500798 BLAKE2B 6b4c8d617e6a649997e9375677baed99315be83e598317ce4951883482e6099cb5fd28e27ae25ab68ecc765931b0955289d144a710ce2e1b11edf92848b1b613 SHA512 e538d022110eef808a7ab040ca58004f1a8759d315ad954455d6da9a088cf80d53489529234fbfdd9fd20b8424d49b4a9635673cd25612c63ef9cc90220a4e82
diff --git a/net-libs/libhtp/libhtp-0.5.44.ebuild b/net-libs/libhtp/libhtp-0.5.44.ebuild
new file mode 100644
index 000000000000..7f787459dab5
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.44.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+IUSE="debug"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.43-configure_fortify_source.patch
+)
+
+# false positive -- function specific to dev-libs/libiconv, which is only used
+# in Windows-based Prefix installations
+QA_CONFIG_IMPL_DECL_SKIP=( iconvctl )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The debug configure logic is broken.
+ econf $(usev debug '--enable-debug')
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+}