summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-09-04 20:53:00 +0000
committerZero_Chaos <zerochaos@gentoo.org>2018-09-04 20:54:28 +0000
commit600fde3abe0fc1c4d197cd383c8405370a317457 (patch)
treeb8ae51ca18ee0f21a359a0bd0809078c757ba10f /net-libs/libiio/libiio-9999.ebuild
parentnet-wireless/soapysdr: add plutosdr support (diff)
downloadgentoo-600fde3abe0fc1c4d197cd383c8405370a317457.tar.gz
gentoo-600fde3abe0fc1c4d197cd383c8405370a317457.tar.bz2
gentoo-600fde3abe0fc1c4d197cd383c8405370a317457.zip
net-libs/libiio: import from pentoo
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'net-libs/libiio/libiio-9999.ebuild')
-rw-r--r--net-libs/libiio/libiio-9999.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-libs/libiio/libiio-9999.ebuild b/net-libs/libiio/libiio-9999.ebuild
new file mode 100644
index 000000000000..64bf1679f217
--- /dev/null
+++ b/net-libs/libiio/libiio-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Library for interfacing with IIO devices"
+HOMEPAGE="https://github.com/analogdevicesinc/libiio"
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/analogdevicesinc/libiio"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/analogdevicesinc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+IUSE="+aio +avahi"
+
+RDEPEND="dev-libs/libxml2:=
+ virtual/libusb:1=
+ aio? ( dev-libs/libaio )
+ avahi? ( net-dns/avahi )"
+DEPEND="${RDEPEND}"