summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-08 16:58:44 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-08 17:00:49 +0200
commit0af6bf4d10b5b494cc7c0cc7c220329ab7d78d7e (patch)
tree9bf23666186c14baf87a4e603e4ee44c3f0e6ad8 /net-libs/liblockfile
parentsci-physics/root: add debug USE flag (diff)
downloadgentoo-0af6bf4d10b5b494cc7c0cc7c220329ab7d78d7e.tar.gz
gentoo-0af6bf4d10b5b494cc7c0cc7c220329ab7d78d7e.tar.bz2
gentoo-0af6bf4d10b5b494cc7c0cc7c220329ab7d78d7e.zip
net-libs/liblockfile: Export AR; Don't run tests when not requested
Closes: https://bugs.gentoo.org/468156 Bug: https://bugs.gentoo.org/691706 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs/liblockfile')
-rw-r--r--net-libs/liblockfile/files/liblockfile-1.15-makefile.patch74
-rw-r--r--net-libs/liblockfile/liblockfile-1.15.ebuild10
2 files changed, 81 insertions, 3 deletions
diff --git a/net-libs/liblockfile/files/liblockfile-1.15-makefile.patch b/net-libs/liblockfile/files/liblockfile-1.15-makefile.patch
new file mode 100644
index 000000000000..952a5703b5d4
--- /dev/null
+++ b/net-libs/liblockfile/files/liblockfile-1.15-makefile.patch
@@ -0,0 +1,74 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -9,8 +9,9 @@ NFSVER = 0.1
+ CFLAGS = @CFLAGS@ -I.
+ LDFLAGS = @LDFLAGS@
+ CC = @CC@
++AR = @AR@
+
+-prefix = $(DESTDIR)@prefix@
++prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ bindir = @bindir@
+ libdir = @libdir@
+@@ -22,7 +23,7 @@ MAILGROUP = @MAILGROUP@
+
+ VERSION = $(shell sed -ne "1s/^liblockfile (\(.*\))/\1/p" < Changelog)
+
+-all: @TARGETS@ test
++all: @TARGETS@
+ install: @INSTALL_TARGETS@
+
+ static: liblockfile.a dotlockfile
+@@ -51,34 +52,34 @@ xlockfile.o: lockfile.c
+ $(CC) $(CFLAGS) -c lockfile.c -o xlockfile.o
+
+ install_static: static install_common
+- install -d -m 755 -g root -p $(libdir)
+- install -m 644 liblockfile.a $(libdir)
++ install -d -m 755 -p $(DESTDIR)$(libdir)
++ install -m 644 liblockfile.a $(DESTDIR)$(libdir)
+
+ install_shared: shared install_static install_common
+- install -d -m 755 -g root -p $(libdir)
++ install -d -m 755 -p $(DESTDIR)$(libdir)
+ install -m 755 liblockfile.so \
+- $(libdir)/liblockfile.so.$(SOVER)
+- ln -s liblockfile.so.$(SOVER) $(libdir)/liblockfile.so.$(MAJOR)
+- ln -s liblockfile.so.$(SOVER) $(libdir)/liblockfile.so
++ $(DESTDIR)$(libdir)/liblockfile.so.$(SOVER)
++ ln -s liblockfile.so.$(SOVER) $(DESTDIR)$(libdir)/liblockfile.so.$(MAJOR)
++ ln -s liblockfile.so.$(SOVER) $(DESTDIR)$(libdir)/liblockfile.so
+ if test "$(DESTDIR)" = ""; then @LDCONFIG@; fi
+
+ install_common:
+- install -d -m 755 -g root -p $(includedir)
+- install -d -m 755 -g root -p $(bindir)
+- install -d -m 755 -g root -p $(mandir)/man1
+- install -d -m 755 -g root -p $(mandir)/man3
+- install -m 644 lockfile.h maillock.h $(includedir)
++ install -d -m 755 -p $(DESTDIR)$(includedir)
++ install -d -m 755 -p $(DESTDIR)$(bindir)
++ install -d -m 755 -p $(DESTDIR)$(mandir)/man1
++ install -d -m 755 -p $(DESTDIR)$(mandir)/man3
++ install -m 644 lockfile.h maillock.h $(DESTDIR)$(includedir)
+ if [ "$(MAILGROUP)" != "" ]; then\
+- install -g $(MAILGROUP) -m 2755 dotlockfile $(bindir);\
++ install -g $(MAILGROUP) -m 2755 dotlockfile $(DESTDIR)$(bindir);\
+ else \
+- install -g root -m 755 dotlockfile $(bindir); \
++ install -m 755 dotlockfile $(DESTDIR)$(bindir); \
+ fi
+- install -m 644 *.1 $(mandir)/man1
+- install -m 644 *.3 $(mandir)/man3
++ install -m 644 *.1 $(DESTDIR)$(mandir)/man1
++ install -m 644 *.3 $(DESTDIR)$(mandir)/man3
+
+ install_nfslib: nfslib
+- install -d -m 755 -g root -p $(nfslockdir)
+- install -m 755 nfslock.so.$(NFSVER) $(nfslockdir)
++ install -d -m 755 -p $(DESTDIR)$(nfslockdir)
++ install -m 755 nfslock.so.$(NFSVER) $(DESTDIR)$(nfslockdir)
+ if test "$(DESTDIR)" = ""; then @LDCONFIG@; fi
+
+ test: test-stamp
diff --git a/net-libs/liblockfile/liblockfile-1.15.ebuild b/net-libs/liblockfile/liblockfile-1.15.ebuild
index bcfa527efdce..4bd4389ffac0 100644
--- a/net-libs/liblockfile/liblockfile-1.15.ebuild
+++ b/net-libs/liblockfile/liblockfile-1.15.ebuild
@@ -3,10 +3,10 @@
EAPI=7
-inherit autotools multilib
+inherit autotools toolchain-funcs multilib
DESCRIPTION="Implements functions designed to lock the standard mailboxes"
-HOMEPAGE="http://www.debian.org/"
+HOMEPAGE="https://www.debian.org/"
SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
LICENSE="LGPL-2"
@@ -20,7 +20,7 @@ DEPEND="${RDEPEND}"
DOCS=( Changelog README )
PATCHES=(
- "${FILESDIR}/${PN}-1.13-makefile.patch"
+ "${FILESDIR}/${PN}-1.15-makefile.patch"
)
src_prepare() {
@@ -43,3 +43,7 @@ src_configure() {
fi
econf --with-mailgroup=${grp} --enable-shared
}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}