summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-12-17 12:42:08 -0500
committerAnthony G. Basile <blueness@gentoo.org>2019-12-17 12:42:08 -0500
commitf3a522e01cf3d05aef6f55de74f5333b4bf81560 (patch)
tree9c4d63022c616408b08076d2e3456e13b036cffa /net-libs/libmicrohttpd
parentnet-firewall/xtables-addons: version bump to 3.7 (diff)
downloadgentoo-f3a522e01cf3d05aef6f55de74f5333b4bf81560.tar.gz
gentoo-f3a522e01cf3d05aef6f55de74f5333b4bf81560.tar.bz2
gentoo-f3a522e01cf3d05aef6f55de74f5333b4bf81560.zip
net-libs/libmicrohttpd: version bump to 0.9.69
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 487c1a9a9718..178d76ac1f42 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -4,3 +4,4 @@ DIST libmicrohttpd-0.9.65.tar.gz 1633346 BLAKE2B ce6ba2b6c52e30194872c66ab5b9e35
DIST libmicrohttpd-0.9.66.tar.gz 1877096 BLAKE2B 4788fa63b0438e250264852f291a7661ee64f4116cbe95eec0902a47115721040a9259acb9c3385d833364f9b27695a90a2cedc516a35ee89125e0852d545579 SHA512 59cc56a9511d9d1c05647a57d920a16d0aaa0d0523d0241ceb88641d18bd95fdb3bb5a60fd648ac54a6f4323a673a3145e520a2fe9e124e78973ff6dac3ad89a
DIST libmicrohttpd-0.9.67.tar.gz 1881973 BLAKE2B 640bc99642160adb6728dfa6ea71720e376bd0bca3b86a56424906a563b9ea1ef92d51c509d0e642c8e32f46a9044826ab41f0e5eef88ee971bde9094a961db7 SHA512 2a2a11e9a525024dada639b1622cc875bb9b59af266a53e2742d5bf92f544192713c4e1369a573b2e3796d27cf490a9a02ba360ccc91136b4780306769edb7ec
DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99a69510a14a802609d038964d927516f8f52b4330d0eee2c7b98096b2d840158e4945310edef290224ea256d9616fb4d94 SHA512 9daaab5fb35fef6f2a19b7e08eeb8473aeb0a67631808a8d7a7f78a09cb621ca5d32dbbbca616865a40afb92f8c6495f9e2ba1674880af8011a2bc798c070a13
+DIST libmicrohttpd-0.9.69.tar.gz 1884511 BLAKE2B 6470b52e58d82a7fee17d8545e546cb9d3fa38012bcf3380d238afdf0f1b5391e19df53a89ac977ac9452d23610dc851f5da5972cace8d8f1088e1040d173572 SHA512 1633d2e606f476489e8af549fff88735e3b5641c85d59071edc8b2e1177fe1b6302578b69b8ff6669d3e1954c20cf0fa1ee52b42378362edd26197d8992e469b
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild
new file mode 100644
index 000000000000..c17a93c12ff6
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+epoll ssl static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}