summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-03-21 15:31:04 +0100
committerJakov Smolić <jsmolic@gentoo.org>2022-03-21 19:48:28 +0100
commitc2752bf41a62e9257146a555580cadf924abbf53 (patch)
tree66f1feaf01db372b176fed212c4da6f5d2d95ee4 /net-libs/libnetconf2
parentnet-libs/libyang: add 2.0.164 (diff)
downloadgentoo-c2752bf41a62e9257146a555580cadf924abbf53.tar.gz
gentoo-c2752bf41a62e9257146a555580cadf924abbf53.tar.bz2
gentoo-c2752bf41a62e9257146a555580cadf924abbf53.zip
net-libs/libnetconf2: add 2.1.7
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs/libnetconf2')
-rw-r--r--net-libs/libnetconf2/Manifest1
-rw-r--r--net-libs/libnetconf2/libnetconf2-2.1.7.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/libnetconf2/Manifest b/net-libs/libnetconf2/Manifest
index 7d48fb58c9bd..6a94e57ef8d0 100644
--- a/net-libs/libnetconf2/Manifest
+++ b/net-libs/libnetconf2/Manifest
@@ -1 +1,2 @@
DIST libnetconf2-2.0.24.tar.gz 301111 BLAKE2B ffc4dffd797e4589a5892f3cf80d6a373808ee48c00e46a37ff02082c721c49b27aa06962e962698d3b443e08e9cba55b4205cc6e76958df325c6fc5a38fed22 SHA512 05cba691bc47e49abf747a36a6dcc978a4163fd155a90609315585201e4e4d20c9a30b683180f5cf03aac5b6a37933917e61a895067dd172b8de2142ec542dfc
+DIST libnetconf2-2.1.7.tar.gz 302011 BLAKE2B b83faebb8d04d9ecaa0bc3aa1fed1bc3b94388d1a6dbc8d3e8c2ff2bb73dc57a460eaf9cc7bf2d07a8e09ef612826417990d8c70bab9c58f9cb71b53766b035b SHA512 fd46a3c31a062324e6c9f2d66006ba8cd852ccb389bf8749d1d0d085b880409e1e373d1d1f2d79c1d88f5eaa72d56195889c07863d0eab1607da89484e21b86f
diff --git a/net-libs/libnetconf2/libnetconf2-2.1.7.ebuild b/net-libs/libnetconf2/libnetconf2-2.1.7.ebuild
new file mode 100644
index 000000000000..b37d8f46bccb
--- /dev/null
+++ b/net-libs/libnetconf2/libnetconf2-2.1.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C library for building NETCONF servers and clients"
+HOMEPAGE="https://github.com/CESNET/libnetconf2"
+SRC_URI="https://github.com/CESNET/libnetconf2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ >=net-libs/libyang-2.0.164
+ net-libs/libssh:0=[server]
+ virtual/libcrypt:="
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_VALGRIND_TESTS=OFF
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}