summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnetfilter_acct
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnetfilter_acct')
-rw-r--r--net-libs/libnetfilter_acct/Manifest1
-rw-r--r--net-libs/libnetfilter_acct/libnetfilter_acct-1.0.2.ebuild47
-rw-r--r--net-libs/libnetfilter_acct/metadata.xml10
3 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/libnetfilter_acct/Manifest b/net-libs/libnetfilter_acct/Manifest
new file mode 100644
index 000000000000..0d9a37709058
--- /dev/null
+++ b/net-libs/libnetfilter_acct/Manifest
@@ -0,0 +1 @@
+DIST libnetfilter_acct-1.0.2.tar.bz2 292718 SHA256 0128f19c3419fbd84f7e6d46b13a33ef7bda9b9f5e493bc5ae1882d087514b71 SHA512 6bd299d509736ce3335e051137851d7f1a3751eafa380b55e9c73a25afb5d45c904ce9acefd4f934f1d21f2ff85b06faed4b072dc74d74e3a8b93342d59f5cdf WHIRLPOOL 00f178afa4720d0ebfa0af2bce14d386d756940eedced27d4a58c68d6593627e70126f8f65bbe73fd8ace8e4200ebd774237c2fc7fda2029f5f7e4a3738e688a
diff --git a/net-libs/libnetfilter_acct/libnetfilter_acct-1.0.2.ebuild b/net-libs/libnetfilter_acct/libnetfilter_acct-1.0.2.ebuild
new file mode 100644
index 000000000000..6e785995bc6f
--- /dev/null
+++ b/net-libs/libnetfilter_acct/libnetfilter_acct-1.0.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils linux-info multilib
+
+DESCRIPTION="Userspace library providing interface to extended accounting infrastructure of NetFilter"
+HOMEPAGE="http://netfilter.org/projects/libnetfilter_acct"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 x86 ~amd64-linux"
+IUSE="examples"
+
+RDEPEND="net-libs/libmnl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+CONFIG_CHECK="~NETFILTER_NETLINK_ACCT"
+
+pkg_setup() {
+ kernel_is lt 3 3 && ewarn "This package will work with kernel version 3.3 or higher"
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf \
+ --libdir="${EPREFIX}"/$(get_libdir)
+}
+
+src_install() {
+ default
+ dodir /usr/$(get_libdir)/pkgconfig/
+ mv "${ED}"/{,usr/}$(get_libdir)/pkgconfig/${PN}.pc || die
+
+ if use examples; then
+ find examples/ -name "Makefile*" -exec rm -f '{}' + || die 'find failed'
+ dodoc -r examples/
+ docompress -x /usr/share/doc/${P}/examples
+ fi
+
+ prune_libtool_files
+}
diff --git a/net-libs/libnetfilter_acct/metadata.xml b/net-libs/libnetfilter_acct/metadata.xml
new file mode 100644
index 000000000000..1870437aa8f1
--- /dev/null
+++ b/net-libs/libnetfilter_acct/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription lang="en">
+libnetfilter_acct is the userspace library that provides a programming
+interface (API) to the extended accounting infrastructure. This information can
+then be used by <pkg>net-firewall/nfacct</pkg>
+</longdescription>
+</pkgmetadata>