summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2020-11-22 10:01:06 -0600
committerErik Mackdanz <stasibear@gentoo.org>2020-11-22 10:01:06 -0600
commit795c402bc6547bacb4a570885ccec543305b689e (patch)
treed3831185df59d121ed38f37cae953703d4f91f02 /net-libs/libnpupnp
parentdev-python/pycairo: Remove old (diff)
downloadgentoo-795c402bc6547bacb4a570885ccec543305b689e.tar.gz
gentoo-795c402bc6547bacb4a570885ccec543305b689e.tar.bz2
gentoo-795c402bc6547bacb4a570885ccec543305b689e.zip
net-libs/libnpupnp: revbump for prior flags change
Should have revbumped with 324522b51aefdbad70ff7e5c3a1a8beb3698519a, doing it now. Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.9, Repoman-3.0.2
Diffstat (limited to 'net-libs/libnpupnp')
-rw-r--r--net-libs/libnpupnp/libnpupnp-4.0.14-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/libnpupnp/libnpupnp-4.0.14-r1.ebuild b/net-libs/libnpupnp/libnpupnp-4.0.14-r1.ebuild
new file mode 100644
index 000000000000..733dfdc33817
--- /dev/null
+++ b/net-libs/libnpupnp/libnpupnp-4.0.14-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A C++ base UPnP library, derived from Portable UPnP, a.k.a libupnp"
+HOMEPAGE="https://framagit.org/medoc92/npupnp"
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/expat
+ net-libs/libmicrohttpd
+ net-misc/curl
+"
+
+src_prepare() {
+ default
+ ./autogen.sh || die
+}
+
+src_configure() {
+ econf \
+ --enable-client \
+ --enable-debug \
+ --enable-device \
+ --enable-gena \
+ --enable-ipv6 \
+ --enable-optssdp \
+ --enable-reuseaddr \
+ --enable-soap \
+ --enable-ssdp \
+ --enable-tools \
+ --enable-webserver
+}