summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2020-11-11 23:03:41 -0600
committerErik Mackdanz <stasibear@gentoo.org>2020-11-11 23:03:41 -0600
commite2990436bce967ea8c782843873100a883d0dd4e (patch)
tree2bc1951142d729bffe34b0247fc2d27478531e7c /net-libs/libnpupnp
parentdev-lang/lua: slotted 5.1 rev bump to fix lua_get_include_dir (diff)
downloadgentoo-e2990436bce967ea8c782843873100a883d0dd4e.tar.gz
gentoo-e2990436bce967ea8c782843873100a883d0dd4e.tar.bz2
gentoo-e2990436bce967ea8c782843873100a883d0dd4e.zip
net-libs/libnpupnp: Add new package 4.0.13
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.9, Repoman-3.0.2
Diffstat (limited to 'net-libs/libnpupnp')
-rw-r--r--net-libs/libnpupnp/Manifest1
-rw-r--r--net-libs/libnpupnp/libnpupnp-4.0.13.ebuild39
-rw-r--r--net-libs/libnpupnp/metadata.xml36
3 files changed, 76 insertions, 0 deletions
diff --git a/net-libs/libnpupnp/Manifest b/net-libs/libnpupnp/Manifest
new file mode 100644
index 000000000000..73b212161a1f
--- /dev/null
+++ b/net-libs/libnpupnp/Manifest
@@ -0,0 +1 @@
+DIST libnpupnp-4.0.13.tar.gz 537389 BLAKE2B 0085d9ea9cf1786bba8e8abb812b0c1279fc30c70a16cb2bf4cfad405ec1346180171dd39296a30f5747cd55ee06fc314bcb49fdb6537a4dfbcf048fb66fd7f5 SHA512 c0332552ab2ba8aea8e72858601f2415a08a68224f724454d230acddf612b2fdd873daf41aeeeb3e1b4d1694665245087b3c4f96c896d36e2e9c017ea95d13aa
diff --git a/net-libs/libnpupnp/libnpupnp-4.0.13.ebuild b/net-libs/libnpupnp/libnpupnp-4.0.13.ebuild
new file mode 100644
index 000000000000..80a418d16497
--- /dev/null
+++ b/net-libs/libnpupnp/libnpupnp-4.0.13.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A C++ base UPnP library, derived from Portable UPnP, a.k.a libupnp"
+HOMEPAGE="https://framagit.org/medoc92/npupnp"
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="client debug device gena ipv6 optssdp reuseaddr soap ssdp tools webserver"
+
+RDEPEND="
+ dev-libs/expat
+ net-libs/libmicrohttpd
+ net-misc/curl
+"
+
+src_prepare() {
+ default
+ ./autogen.sh || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable client) \
+ $(use_enable debug) \
+ $(use_enable device) \
+ $(use_enable gena) \
+ $(use_enable ipv6) \
+ $(use_enable optssdp) \
+ $(use_enable reuseaddr) \
+ $(use_enable soap) \
+ $(use_enable ssdp) \
+ $(use_enable tools) \
+ $(use_enable webserver)
+}
diff --git a/net-libs/libnpupnp/metadata.xml b/net-libs/libnpupnp/metadata.xml
new file mode 100644
index 000000000000..63aca78f5079
--- /dev/null
+++ b/net-libs/libnpupnp/metadata.xml
@@ -0,0 +1,36 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!--
+ This is the example metadata file.
+ The root element of this file is <pkgmetadata>. Within this element a
+ number of subelements are allowed, the most common being maintainer.
+
+ For a full description look at:
+ https://devmanual.gentoo.org/ebuild-writing/misc-files/metadata/
+
+ Before committing, please remove the comments from this file. They are
+ not relevant for general metadata.xml files.
+-->
+<pkgmetadata>
+ <maintainer type="person">
+ <email>stasibear@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <longdescription>
+ The libupnpp library, which provides the C++ interface for
+ upmpdcli and upplay, used to rely on the venerable libupnp library
+ (a.k.a pupnp: Portable UPnP) to provide the base UPnP protocol
+ functionality.
+ </longdescription>
+ <use>
+ <flag name="client">control point code (client)</flag>
+ <flag name="device">device specific code (implies -webserver if disabled)</flag>
+ <flag name="gena">GENA part</flag>
+ <flag name="optssdp">optional SSDP headers support</flag>
+ <flag name="reuseaddr">bind the miniserver socket with reuseaddr</flag>
+ <flag name="soap">SOAP part</flag>
+ <flag name="ssdp">SSDP part</flag>
+ <flag name="tools">helper APIs in upnptools.h</flag>
+ <flag name="webserver">integrated web server</flag>
+ </use>
+</pkgmetadata>