summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libpcapnav
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libpcapnav')
-rw-r--r--net-libs/libpcapnav/Manifest1
-rw-r--r--net-libs/libpcapnav/files/libpcapnav-0.8-includes.patch20
-rw-r--r--net-libs/libpcapnav/libpcapnav-0.8.ebuild41
-rw-r--r--net-libs/libpcapnav/metadata.xml8
4 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/libpcapnav/Manifest b/net-libs/libpcapnav/Manifest
new file mode 100644
index 000000000000..fddd5bcf02d7
--- /dev/null
+++ b/net-libs/libpcapnav/Manifest
@@ -0,0 +1 @@
+DIST libpcapnav-0.8.tar.gz 387476 SHA256 11d6a4257cbc5a89aa73ce2aaa5b0fc17430f7279d0abb39ccaf3a411ba7e852 SHA512 bc0357d17228c157de5b480532df37a62459882d5a4fb8d2285fe4e86c1dca301e7cc505f2917bb3421d926bed263d93b2c587311431d9c3a5b02f04c93fdf18 WHIRLPOOL 08552c55bc6d2c80780b333e1ba0c476baa5d783c74309fe6e435cefae551b9d2a27040c66e2f27ee21a8679f48a3fe8f258a9efc64873fbda806656e339a974
diff --git a/net-libs/libpcapnav/files/libpcapnav-0.8-includes.patch b/net-libs/libpcapnav/files/libpcapnav-0.8-includes.patch
new file mode 100644
index 000000000000..cb41bedf4a32
--- /dev/null
+++ b/net-libs/libpcapnav/files/libpcapnav-0.8-includes.patch
@@ -0,0 +1,20 @@
+--- a/test/pcapnav-test1.c
++++ b/test/pcapnav-test1.c
+@@ -1,6 +1,7 @@
+ #include <config.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <time.h> /* ctime() */
+
+ #include <pcapnav.h>
+
+--- a/test/pcapnav-jump.c
++++ b/test/pcapnav-jump.c
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <pcapnav.h>
++#include <string.h> /* strcmp() */
+
+ int
+ main(int argc, char** argv)
diff --git a/net-libs/libpcapnav/libpcapnav-0.8.ebuild b/net-libs/libpcapnav/libpcapnav-0.8.ebuild
new file mode 100644
index 000000000000..b87808f6f8fa
--- /dev/null
+++ b/net-libs/libpcapnav/libpcapnav-0.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="Libpcap wrapper library to navigate to arbitrary packets in a tcpdump trace file"
+HOMEPAGE="http://netdude.sourceforge.net/"
+SRC_URI="mirror://sourceforge/netdude/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~sparc x86"
+IUSE="doc static-libs"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-includes.patch
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake SUBDIRS="src docs"
+}
+
+src_install() {
+ default
+ rm -fr "${D}"/usr/share/gtk-doc
+ use doc && dohtml -r docs/*.css docs/html/*.html docs/images
+ prune_libtool_files
+}
diff --git a/net-libs/libpcapnav/metadata.xml b/net-libs/libpcapnav/metadata.xml
new file mode 100644
index 000000000000..89664012b677
--- /dev/null
+++ b/net-libs/libpcapnav/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <upstream>
+ <remote-id type="sourceforge">netdude</remote-id>
+ </upstream>
+</pkgmetadata>