summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libproxy/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libproxy/files')
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch29
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.11-avoid-nm-build-dep.patch60
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.11-macosx.patch86
-rw-r--r--net-libs/libproxy/files/libproxy-0.4.11-mozjs.pc.patch23
4 files changed, 198 insertions, 0 deletions
diff --git a/net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch b/net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch
new file mode 100644
index 000000000000..91658574134e
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.10-disable-pac-test.patch
@@ -0,0 +1,29 @@
+From 5a1a8d2b920006e54d9de971999b443073f50843 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Tue, 16 Oct 2012 03:30:50 -0400
+Subject: [PATCH] Disable PAC test
+
+get-pac-test freezes when run from the ebuild, but succeeds when
+building manually. Using Xemake/virtualx.eclass doesn't seem to help.
+---
+ libproxy/test/CMakeLists.txt | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/libproxy/test/CMakeLists.txt b/libproxy/test/CMakeLists.txt
+index 8894425..69543a4 100644
+--- a/libproxy/test/CMakeLists.txt
++++ b/libproxy/test/CMakeLists.txt
+@@ -17,10 +17,3 @@ if(WIN32)
+ target_link_libraries(url-encode ws2_32)
+ endif()
+ add_test(NAME url-encode COMMAND ${CMAKE_CURRENT_BINARY_DIR}/url-encode)
+-
+-# Get PAC
+-if (NOT WIN32)
+-add_executable(get-pac-test ${CMAKE_CURRENT_SOURCE_DIR}/get-pac-test.cpp ${PROJECT_SOURCE_DIR}/url.cpp)
+-target_link_libraries(get-pac-test pthread)
+-add_test(NAME get-pac-test COMMAND ${CMAKE_CURRENT_BINARY_DIR}/get-pac-test)
+-endif()
+--
+1.7.12.3
+
diff --git a/net-libs/libproxy/files/libproxy-0.4.11-avoid-nm-build-dep.patch b/net-libs/libproxy/files/libproxy-0.4.11-avoid-nm-build-dep.patch
new file mode 100644
index 000000000000..59e368b696eb
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.11-avoid-nm-build-dep.patch
@@ -0,0 +1,60 @@
+From 518214ee85e10c5bc99d3b115ae7ac9cc3fc14fc Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 29 Apr 2013 23:02:25 -0400
+Subject: [PATCH] Avoid build-time dependency on NetworkManager
+
+Needed to prevent a dependency loop:
+nm -> libsoup -> glib-networking -> libproxy -> nm
+
+https://bugs.gentoo.org/467696
+---
+ libproxy/cmake/modules/network_networkmanager.cmk | 4 ++--
+ libproxy/modules/network_networkmanager.cpp | 21 ++++++++++++++++++++-
+ 2 files changed, 22 insertions(+), 3 deletions(-)
+
+diff --git a/libproxy/cmake/modules/network_networkmanager.cmk b/libproxy/cmake/modules/network_networkmanager.cmk
+index d9f9588..2586bbd 100644
+--- a/libproxy/cmake/modules/network_networkmanager.cmk
++++ b/libproxy/cmake/modules/network_networkmanager.cmk
+@@ -1,3 +1,3 @@
+ if (NOT WIN32 AND NOT APPLE)
+- px_check_modules(NM NetworkManager dbus-1)
+-endif()
+\ No newline at end of file
++ px_check_modules(NM dbus-1)
++endif()
+diff --git a/libproxy/modules/network_networkmanager.cpp b/libproxy/modules/network_networkmanager.cpp
+index 564c275..a03425b 100644
+--- a/libproxy/modules/network_networkmanager.cpp
++++ b/libproxy/modules/network_networkmanager.cpp
+@@ -23,7 +23,26 @@
+ using namespace libproxy;
+
+ #include <dbus/dbus.h>
+-#include <NetworkManager/NetworkManager.h>
++
++
++/*
++ * copy-pasted from NetworkManager-0.9.6.4's NetworkManager.h to prevent
++ * a circular dependency; https://bugs.gentoo.org/467696
++ */
++#define NM_DBUS_PATH "/org/freedesktop/NetworkManager"
++#define NM_DBUS_INTERFACE "org.freedesktop.NetworkManager"
++typedef enum {
++ NM_STATE_UNKNOWN = 0,
++ NM_STATE_ASLEEP = 10,
++ NM_STATE_DISCONNECTED = 20,
++ NM_STATE_DISCONNECTING = 30,
++ NM_STATE_CONNECTING = 40,
++ NM_STATE_CONNECTED_LOCAL = 50,
++ NM_STATE_CONNECTED_SITE = 60,
++ NM_STATE_CONNECTED_GLOBAL = 70
++} NMState;
++#define NM_STATE_CONNECTED NM_STATE_CONNECTED_GLOBAL
++
+
+ class networkmanager_network_extension : public network_extension {
+ public:
+--
+1.8.2.1
+
diff --git a/net-libs/libproxy/files/libproxy-0.4.11-macosx.patch b/net-libs/libproxy/files/libproxy-0.4.11-macosx.patch
new file mode 100644
index 000000000000..09558e3c4d76
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.11-macosx.patch
@@ -0,0 +1,86 @@
+https://trac.macports.org/browser/trunk/dports/net/libproxy/files/patch-libproxy-cmake.diff
+
+diff -ur libproxy/cmake.orig/libproxy.cmk libproxy/cmake/libproxy.cmk
+--- libproxy/cmake.orig/libproxy.cmk 2012-10-02 07:20:40.000000000 -0700
++++ libproxy/cmake/libproxy.cmk 2012-10-19 13:47:50.000000000 -0700
+@@ -18,7 +18,7 @@
+ set_property(SOURCE ${CMAKE_CURRENT_SOURCE_DIR}/proxy.cpp
+ PROPERTY COMPILE_DEFINITIONS MODULEDIR="${MODULEDIR}";BUILTIN_MODULES=${BUILTIN_MODULES})
+ # When changing the SOVERSION here remember to also bump the 'favorite proxy .so' in python bindings.
+-set_target_properties(libproxy PROPERTIES PREFIX "" VERSION 1.0.0 SOVERSION 1)
++set_target_properties(libproxy PROPERTIES INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/lib" PREFIX "" VERSION 1.0.0 SOVERSION 1)
+ set_target_properties(libproxy PROPERTIES LINK_INTERFACE_LIBRARIES "")
+ install(TARGETS libproxy DESTINATION ${LIB_INSTALL_DIR})
+ install(FILES proxy.h DESTINATION ${INCLUDE_INSTALL_DIR})
+diff -ur libproxy/cmake.orig/modules/config_envvar.cmk libproxy/cmake/modules/config_envvar.cmk
+--- libproxy/cmake.orig/modules/config_envvar.cmk 2010-06-14 10:40:47.000000000 -0700
++++ libproxy/cmake/modules/config_envvar.cmk 2012-10-19 13:45:42.000000000 -0700
+@@ -1,3 +1,3 @@
+-if (NOT WIN32 AND NOT APPLE)
++if (NOT WIN32 AND NOT (APPLE AND MP_MACOSX))
+ set(ENVVAR_FOUND 1)
+-endif()
+\ No newline at end of file
++endif()
+diff -ur libproxy/cmake.orig/modules/config_gnome.cmk libproxy/cmake/modules/config_gnome.cmk
+--- libproxy/cmake.orig/modules/config_gnome.cmk 2012-10-02 07:20:40.000000000 -0700
++++ libproxy/cmake/modules/config_gnome.cmk 2012-10-19 13:45:42.000000000 -0700
+@@ -1,4 +1,4 @@
+-if (NOT WIN32 AND NOT APPLE)
++if (NOT WIN32 AND NOT (APPLE AND MP_MACOSX))
+ option(WITH_GNOME2 "Target a GNOME 2 system (gconf)" OFF)
+ option(WITH_GNOME3 "Target a GNOME 3 system (gsettings)" ON)
+ if(WITH_GNOME3)
+diff -ur libproxy/cmake.orig/modules/config_kde4.cmk libproxy/cmake/modules/config_kde4.cmk
+--- libproxy/cmake.orig/modules/config_kde4.cmk 2010-06-14 10:40:47.000000000 -0700
++++ libproxy/cmake/modules/config_kde4.cmk 2012-10-19 13:45:42.000000000 -0700
+@@ -1,4 +1,4 @@
+-if (NOT WIN32 AND NOT APPLE)
++if (NOT WIN32 AND NOT (APPLE AND MP_MACOSX))
+ option(WITH_KDE4 "Search for KDE4 package" ON)
+ if (WITH_KDE4)
+ find_package(KDE4)
+@@ -16,4 +16,4 @@
+ else()
+ set(KDE4_FOUND 0)
+ endif()
+-endif()
+\ No newline at end of file
++endif()
+diff -ur libproxy/cmake.orig/modules/config_macosx.cmk libproxy/cmake/modules/config_macosx.cmk
+--- libproxy/cmake.orig/modules/config_macosx.cmk 2010-06-14 10:40:47.000000000 -0700
++++ libproxy/cmake/modules/config_macosx.cmk 2012-10-19 13:45:42.000000000 -0700
+@@ -1,4 +1,4 @@
+-if(APPLE)
++if(APPLE AND MP_MACOSX)
+ find_library(SC_LIBRARIES SystemConfiguration)
+ find_library(CF_LIBRARIES CoreFoundation)
+ if(SC_LIBRARIES)
+@@ -7,4 +7,4 @@
+ if(CF_LIBRARIES)
+ set(CF_FOUND 1)
+ endif()
+-endif()
+\ No newline at end of file
++endif()
+diff -ur libproxy/cmake.orig/modules/pacrunner_webkit.cmk libproxy/cmake/modules/pacrunner_webkit.cmk
+--- libproxy/cmake.orig/modules/pacrunner_webkit.cmk 2012-10-02 07:20:40.000000000 -0700
++++ libproxy/cmake/modules/pacrunner_webkit.cmk 2012-10-19 13:45:42.000000000 -0700
+@@ -6,7 +6,7 @@
+ link_directories(WEBKIT_LIBRARIES)
+ include_directories("${WEBKIT_INCLUDE_DIR}")
+ endif()
+-elseif(APPLE)
++elseif(APPLE AND MP_MACOSX)
+ find_library(WEBKIT_LIBRARIES JavaScriptCore)
+ if(WEBKIT_LIBRARIES)
+ set(WEBKIT_FOUND 1)
+diff -ur libproxy/cmake.orig/pkgconfig.cmk libproxy/cmake/pkgconfig.cmk
+--- libproxy/cmake.orig/pkgconfig.cmk 2012-10-02 07:20:40.000000000 -0700
++++ libproxy/cmake/pkgconfig.cmk 2012-10-19 13:45:42.000000000 -0700
+@@ -1,4 +1,4 @@
+-if(NOT WIN32 AND NOT APPLE)
++if(NOT WIN32 AND NOT (APPLE AND MP_MACOSX))
+ find_package(PkgConfig)
+
+ # Define our magical px_check_modules function
diff --git a/net-libs/libproxy/files/libproxy-0.4.11-mozjs.pc.patch b/net-libs/libproxy/files/libproxy-0.4.11-mozjs.pc.patch
new file mode 100644
index 000000000000..8d8d21e65136
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.4.11-mozjs.pc.patch
@@ -0,0 +1,23 @@
+--- libproxy-0.4.11/libproxy/cmake/modules/pacrunner_mozjs.cmk.orig 2011-06-20 04:31:41.000000000 -0600
++++ libproxy-0.4.11/libproxy/cmake/modules/pacrunner_mozjs.cmk 2013-03-24 19:20:17.910765954 -0600
+@@ -9,12 +9,18 @@
+ elseif(NOT APPLE)
+ option(WITH_MOZJS "Search for MOZJS package" ON)
+ if (WITH_MOZJS)
+- pkg_search_module(MOZJS mozjs185>=1.8.5)
++ pkg_search_module(MOZJS mozjs187)
+ if(MOZJS_FOUND)
+ include_directories(${MOZJS_INCLUDE_DIRS})
+ link_directories(${MOZJS_LIBRARY_DIRS})
+ else()
+- set(MOZJS_FOUND 0)
++ pkg_search_module(MOZJS mozjs185)
++ if(MOZJS_FOUND)
++ include_directories(${MOZJS_INCLUDE_DIRS})
++ link_directories(${MOZJS_LIBRARY_DIRS})
++ else()
++ set(MOZJS_FOUND 0)
++ endif()
+ endif()
+ else()
+ set(MOZJS_FOUND 0)