summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-08-04 21:50:58 +1000
committerMichael Palimaka <kensington@gentoo.org>2019-08-04 21:51:24 +1000
commitebf753a60fc2d705cf613a00842896ddc2c735ff (patch)
treeb7441719bbfe908a94ac495677cd9013a87adbfa /net-libs/libsignon-glib
parentsys-apps/most: Bump to version 5.1.0 (diff)
downloadgentoo-ebf753a60fc2d705cf613a00842896ddc2c735ff.tar.gz
gentoo-ebf753a60fc2d705cf613a00842896ddc2c735ff.tar.bz2
gentoo-ebf753a60fc2d705cf613a00842896ddc2c735ff.zip
net-libs/libsignon-glib: version bump 2.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'net-libs/libsignon-glib')
-rw-r--r--net-libs/libsignon-glib/Manifest1
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-2.1.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-libs/libsignon-glib/Manifest b/net-libs/libsignon-glib/Manifest
index 4836858a6f6b..eb7a3d38b727 100644
--- a/net-libs/libsignon-glib/Manifest
+++ b/net-libs/libsignon-glib/Manifest
@@ -1 +1,2 @@
DIST libsignon-glib-1.14.tar.gz 54019 BLAKE2B 9ffdb96a374ef0848c1b70cb369a533ea826b24856a32b4b454a0fd8982533041fcc88382fdf1eee6857aa36ec8d076885fc769a058e148e91da54dbddaf7125 SHA512 c2277933d6ec2c3288ce510c853da7719116dac15d60c7114fcdcb87d04e7f70390d066938dea6aa0f819fbd70158fb875c5be5684c47fd27c0b6c55e9467a1d
+DIST libsignon-glib-2.1.tar.gz 52440 BLAKE2B edc27f5f09c3f6d05f32ff6b560934dc003072940b44932fd90021511510fb56beaec7f25dd051b3c1d12d10942f292cc906a9fc4b74bb7f2daf8b885f15e644 SHA512 45d8e26263a16b98517cda0fff8e46fb1ffcc4bb833a6364454f120eb9819b48ee04bdb338bf5e9f0b0fe344af5940f35ed56f0765ca3605dead5b3755657dcf
diff --git a/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild b/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
new file mode 100644
index 000000000000..9e76f9f843a9
--- /dev/null
+++ b/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit meson python-r1 vala vcs-snapshot
+
+DESCRIPTION="GLib binding for the D-Bus API provided by signond"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/${PN}/-/archive/VERSION_${PV}/${PN}-VERSION_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="debug doc +introspection python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} introspection )"
+
+RDEPEND="
+ dev-libs/glib:2
+ net-libs/signond
+ introspection? ( dev-libs/gobject-introspection:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ doc? ( dev-util/gtk-doc )
+ test? ( dev-libs/check )
+"
+
+#DOCS=( AUTHORS NEWS README.md )
+
+# needs more love
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ vala_src_prepare
+
+ use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+
+ cp libsignon-glib/*.xml libsignon-glib/interfaces || die
+}
+
+src_configure() {
+ myconfigure() {
+ local emesonargs=(
+ -Ddebugging=$(usex debug true false)
+ -Dintrospection=$(usex introspection true false)
+ -Dpython=$(usex python true false)
+ -Dtests=$(usex test true false)
+ )
+
+ meson_src_configure
+ }
+
+ if use python; then
+# python_copy_sources
+ python_foreach_impl run_in_build_dir myconfigure
+ else
+ myconfigure
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir meson_src_compile
+ else
+ meson_src_compile
+ fi
+}
+
+src_compile() {
+ if use python; then
+ python_foreach_impl run_in_build_dir meson_src_test
+ else
+ meson_src_test
+ fi
+}
+
+src_install() {
+ einstalldocs
+
+ if use python; then
+ python_foreach_impl run_in_build_dir meson_src_install
+ else
+ meson_src_install
+ fi
+}