summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 13:57:48 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:43 +0100
commit4204aed71ec2d1b2413df056e74191a61c393e53 (patch)
tree16b5bd4eebd1657716b36eca8e4c399a1bcf8638 /net-libs/libssh/libssh-0.9.3.ebuild
parentcmake-multilib.eclass: Add CMAKE_ECLASS switch (diff)
downloadgentoo-4204aed71ec2d1b2413df056e74191a61c393e53.tar.gz
gentoo-4204aed71ec2d1b2413df056e74191a61c393e53.tar.bz2
gentoo-4204aed71ec2d1b2413df056e74191a61c393e53.zip
*/*: Switch kde proj packages using cmake-multilib.eclass to cmake
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libssh/libssh-0.9.3.ebuild')
-rw-r--r--net-libs/libssh/libssh-0.9.3.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-libs/libssh/libssh-0.9.3.ebuild b/net-libs/libssh/libssh-0.9.3.ebuild
index 3ead343c58fe..c015fb647b0e 100644
--- a/net-libs/libssh/libssh-0.9.3.ebuild
+++ b/net-libs/libssh/libssh-0.9.3.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Access a working SSH implementation by means of a library"
@@ -49,7 +50,7 @@ PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
RESTRICT+=" !test? ( test )"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# just install the examples, do not compile them
cmake_comment_add_subdirectory examples
@@ -88,16 +89,16 @@ multilib_src_configure() {
multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
- multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+ cmake_src_compile
+ multilib_is_native_abi && use doc && cmake_src_compile docs
}
multilib_src_install() {
- cmake-utils_src_install
+ cmake_src_install
multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
use static-libs && dolib.a src/libssh.a