summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-08 10:43:49 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-08 10:56:15 +0200
commit51e85ff55bbda8f037c853712b899dd725eb875f (patch)
treed5cb32d720eaedde69842293742ac59f660b0b9c /net-libs/libssh2
parentgames-strategy/colobot: Improve description (diff)
downloadgentoo-51e85ff55bbda8f037c853712b899dd725eb875f.tar.gz
gentoo-51e85ff55bbda8f037c853712b899dd725eb875f.tar.bz2
gentoo-51e85ff55bbda8f037c853712b899dd725eb875f.zip
net-libs/libssh2: Port to cmake.eclass
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild3
-rw-r--r--net-libs/libssh2/libssh2-9999.ebuild5
2 files changed, 5 insertions, 3 deletions
diff --git a/net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild b/net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild
index f75ac77f2f15..9850017d5700 100644
--- a/net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild
+++ b/net-libs/libssh2/libssh2-1.9.0_p20190913.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
EGIT_COMMIT=336bd86d2ca4030b808d76e56a0387914982e289
@@ -50,7 +51,7 @@ multilib_src_configure() {
-DCRYPTO_BACKEND=${crypto_backend}
-DENABLE_ZLIB_COMPRESSION=$(usex zlib)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_install_all() {
diff --git a/net-libs/libssh2/libssh2-9999.ebuild b/net-libs/libssh2/libssh2-9999.ebuild
index 5bf05457d9ad..ecb95eb5807f 100644
--- a/net-libs/libssh2/libssh2-9999.ebuild
+++ b/net-libs/libssh2/libssh2-9999.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+CMAKE_ECLASS=cmake
inherit git-r3 cmake-multilib
DESCRIPTION="Library implementing the SSH2 protocol"
@@ -47,7 +48,7 @@ multilib_src_configure() {
-DCRYPTO_BACKEND=${crypto_backend}
-DENABLE_ZLIB_COMPRESSION=$(usex zlib)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_install_all() {