summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libtelnet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libtelnet')
-rw-r--r--net-libs/libtelnet/Manifest1
-rw-r--r--net-libs/libtelnet/libtelnet-0.21.ebuild34
-rw-r--r--net-libs/libtelnet/libtelnet-9999.ebuild34
-rw-r--r--net-libs/libtelnet/metadata.xml11
4 files changed, 80 insertions, 0 deletions
diff --git a/net-libs/libtelnet/Manifest b/net-libs/libtelnet/Manifest
new file mode 100644
index 000000000000..177b6de4f3d7
--- /dev/null
+++ b/net-libs/libtelnet/Manifest
@@ -0,0 +1 @@
+DIST libtelnet-0.21.tar.gz 240486 SHA256 fb4b02106b77c00ff5e1c15159d681a1a70962a1b087151061726075ec2ce445 SHA512 69dc0ac4741c81d932136cd736b48a11a05cd2738da6255d6050844f50a2f16c575c747e5c758bbdbc6b1e3309ce02e4979f0002b40fed32a3711aa8f22e04f1 WHIRLPOOL 889d53bed552939c4540747a21b3301de4cc721af3c86bfd4eee6fc9c3a6aa6f2f8e07172c2af84566e3f31723864d57fc6dbd98ecc59e6a13ef8dc599ca1413
diff --git a/net-libs/libtelnet/libtelnet-0.21.ebuild b/net-libs/libtelnet/libtelnet-0.21.ebuild
new file mode 100644
index 000000000000..922047875bec
--- /dev/null
+++ b/net-libs/libtelnet/libtelnet-0.21.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+
+if [ ${PV} = 9999 ]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/seanmiddleditch/${PN}.git"
+ inherit git-2
+ DEPEND="dev-vcs/git"
+ S="${WORKDIR}/${PN}-master"
+else
+ KEYWORDS="~x86 ~amd64"
+ SRC_URI="https://github.com/seanmiddleditch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+WANT_AUTOMAKE=1.11
+DEPEND="${DEPEND} sys-devel/automake:${WANT_AUTOMAKE}"
+LICENSE="public-domain"
+SLOT="0"
+IUSE=""
+RDEPEND=""
+
+src_prepare() {
+ _elibtoolize
+ eaclocal
+ eautoconf
+ eautoheader
+ eautomake
+}
diff --git a/net-libs/libtelnet/libtelnet-9999.ebuild b/net-libs/libtelnet/libtelnet-9999.ebuild
new file mode 100644
index 000000000000..922047875bec
--- /dev/null
+++ b/net-libs/libtelnet/libtelnet-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+
+if [ ${PV} = 9999 ]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="https://github.com/seanmiddleditch/${PN}.git"
+ inherit git-2
+ DEPEND="dev-vcs/git"
+ S="${WORKDIR}/${PN}-master"
+else
+ KEYWORDS="~x86 ~amd64"
+ SRC_URI="https://github.com/seanmiddleditch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+WANT_AUTOMAKE=1.11
+DEPEND="${DEPEND} sys-devel/automake:${WANT_AUTOMAKE}"
+LICENSE="public-domain"
+SLOT="0"
+IUSE=""
+RDEPEND=""
+
+src_prepare() {
+ _elibtoolize
+ eaclocal
+ eautoconf
+ eautoheader
+ eautomake
+}
diff --git a/net-libs/libtelnet/metadata.xml b/net-libs/libtelnet/metadata.xml
new file mode 100644
index 000000000000..e9303fc9e524
--- /dev/null
+++ b/net-libs/libtelnet/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>nativemad@gentoo.org</email>
+ <name>Andreas Schuerch</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">seanmiddleditch/libtelnet</remote-id>
+ </upstream>
+</pkgmetadata>