summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-07-06 13:09:46 +0200
committerJeroen Roovers <jer@gentoo.org>2018-07-06 13:18:30 +0200
commitd55d188ac24838bf5c1cfdf945f053e74bad986b (patch)
treea9f450a628b766498fef65e54ab074ce6886f643 /net-libs/libtrace
parentdev-util/debhelper: Version 11.3.5. (diff)
downloadgentoo-d55d188ac24838bf5c1cfdf945f053e74bad986b.tar.gz
gentoo-d55d188ac24838bf5c1cfdf945f053e74bad986b.tar.bz2
gentoo-d55d188ac24838bf5c1cfdf945f053e74bad986b.zip
net-libs/libtrace: Fix LICENSE.
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'net-libs/libtrace')
-rw-r--r--net-libs/libtrace/Manifest1
-rw-r--r--net-libs/libtrace/libtrace-4.0.3.ebuild2
-rw-r--r--net-libs/libtrace/libtrace-4.0.4.ebuild58
3 files changed, 60 insertions, 1 deletions
diff --git a/net-libs/libtrace/Manifest b/net-libs/libtrace/Manifest
index 32c44aa9c743..97bba15ff6e9 100644
--- a/net-libs/libtrace/Manifest
+++ b/net-libs/libtrace/Manifest
@@ -1,2 +1,3 @@
DIST libtrace-4.0.2.tar.gz 934255 BLAKE2B 776761288aadbafc812695db9b2af7f2ace3789925e957ae5bd6bfbdb883e49af324a903ea66e303e151300e8a31467b270a45e2dab4d8af1fe2b0e981f188ea SHA512 246fb1812b9c46b7ef543c16159849bb420db633b0778a375f616286cc26988d42542dcecd47256c03d637ceaa97d60168f0ce34b9892d957a3bcae89d984514
DIST libtrace-4.0.3.tar.gz 938865 BLAKE2B b3f7cda52f18fe2905f53af61459c238fe2630c1ffca8189ed73c010a6fd057f04beca9979fc0f515de4797f1aee383b57ddc63dc9a08a88bae5946a9949f010 SHA512 08da665ed355b48daa006119261af7dc1c1a64c193efcd736e91394753f4b3c46af074044d970242d2396389577d92137264acdbb6ab70cdc69a6e3965f742ae
+DIST libtrace-4.0.4.tar.gz 949490 BLAKE2B 63b4e3bee7502deabbb07891ffe81fbed81f6b3b6c8b78148b035565fbb4e9f8302ee8f824e35584e68c453e61b0459f5a602b471330e6e0abae747a80f65872 SHA512 255a0654f762f9185ef70969225a160c017d50e0b01d1e90c31f555c1ebf5ce6509931f0c78bbed183e670d6acecb68e23efb8009a0e236fddd3a8f032401def
diff --git a/net-libs/libtrace/libtrace-4.0.3.ebuild b/net-libs/libtrace/libtrace-4.0.3.ebuild
index a639a3ebd159..30734d72f4b6 100644
--- a/net-libs/libtrace/libtrace-4.0.3.ebuild
+++ b/net-libs/libtrace/libtrace-4.0.3.ebuild
@@ -8,7 +8,7 @@ DESCRIPTION="A library and tools for trace processing"
HOMEPAGE="http://research.wand.net.nz/software/libtrace.php"
SRC_URI="http://research.wand.net.nz/software/${PN}/${P/_/-}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc ncurses numa static-libs"
diff --git a/net-libs/libtrace/libtrace-4.0.4.ebuild b/net-libs/libtrace/libtrace-4.0.4.ebuild
new file mode 100644
index 000000000000..30734d72f4b6
--- /dev/null
+++ b/net-libs/libtrace/libtrace-4.0.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="A library and tools for trace processing"
+HOMEPAGE="http://research.wand.net.nz/software/libtrace.php"
+SRC_URI="http://research.wand.net.nz/software/${PN}/${P/_/-}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc ncurses numa static-libs"
+
+RDEPEND="
+ >=net-libs/libpcap-0.8
+ dev-libs/openssl:0=
+ ncurses? ( sys-libs/ncurses:0= )
+ net-libs/wandio
+ numa? ( sys-process/numactl )
+"
+DEPEND="
+ ${RDEPEND}
+ app-doc/doxygen
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.20-autoconf-1.13.patch
+ "${FILESDIR}"/${PN}-3.0.20-tinfo.patch
+ "${FILESDIR}"/${PN}-4.0.0-no-examples.patch
+ "${FILESDIR}"/${PN}-4.0.0-with-numa.patch
+)
+S=${WORKDIR}/${P/_beta/}
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with ncurses) \
+ $(use_with numa) \
+ --with-man
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r docs/doxygen/html
+
+ prune_libtool_files --modules
+}