summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2020-08-24 19:25:07 +0100
committerIan Whyman <thev00d00@gentoo.org>2020-08-24 19:25:21 +0100
commit4073dfd4f685b52ad6acdc2456121f1d6140b2f5 (patch)
tree63dd38ed81a90e2ec1edb3e6f894730b608d33db /net-libs/libupnp/libupnp-1.14.0.ebuild
parentdev-ruby/facter: 3.14.13 bump (diff)
downloadgentoo-4073dfd4f685b52ad6acdc2456121f1d6140b2f5.tar.gz
gentoo-4073dfd4f685b52ad6acdc2456121f1d6140b2f5.tar.bz2
gentoo-4073dfd4f685b52ad6acdc2456121f1d6140b2f5.zip
net-libs/libupnp: Version bump
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
Diffstat (limited to 'net-libs/libupnp/libupnp-1.14.0.ebuild')
-rw-r--r--net-libs/libupnp/libupnp-1.14.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/libupnp/libupnp-1.14.0.ebuild b/net-libs/libupnp/libupnp-1.14.0.ebuild
new file mode 100644
index 000000000000..79c4ade3f905
--- /dev/null
+++ b/net-libs/libupnp/libupnp-1.14.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils flag-o-matic autotools vcs-snapshot
+
+DESCRIPTION="An Portable Open Source UPnP Development Kit"
+HOMEPAGE="http://pupnp.sourceforge.net/"
+SRC_URI="https://github.com/mrjimenez/pupnp/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="blocking-tcp debug doc ipv6 +reuseaddr samples static-libs"
+
+DOCS="ChangeLog"
+
+src_prepare() {
+ default
+
+ # fix tests
+ chmod +x ixml/test/test_document.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use x86-fbsd && append-flags -O1
+ # w/o docdir to avoid sandbox violations
+ econf $(use_enable debug) \
+ $(use_enable blocking-tcp blocking-tcp-connections) \
+ $(use_enable ipv6) \
+ $(use_enable reuseaddr) \
+ $(use_enable static-libs static) \
+ $(use_enable samples)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${D}" -name '*.la' -delete || die
+}