summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch')
-rw-r--r--net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch b/net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch
new file mode 100644
index 000000000000..2e6939e8860f
--- /dev/null
+++ b/net-libs/libvncserver/files/libvncserver-0.9.10-libva-1.0.patch
@@ -0,0 +1,52 @@
+commit 7b6243157f042a7bde353abc6fb22aadad6d9e2d
+Author: Floris Bos <bos@je-eigen-domein.nl>
+Date: 2014-12-29 00:02:33 +0100
+
+ Fix libva related compile errors
+
+ - Make h264.c compile with recent libva version by including va_compat.h
+ - Only enable libva if libva-x11 is installed
+ - Modified configure help text
+ Previous help text suggested libva was only build when --with-libva
+ was specified, while actual behavior is to build it by default.
+
+ Warning: THIS CODE IS UNTESTED. Lacking a h.264 capable VNC server
+ Also no attempt is made to support platforms not using X11
+
+ Signed-off-by: Floris Bos <bos@je-eigen-domein.nl>
+
+diff --git a/configure.ac b/configure.ac
+index ca9f3b3..fe8b1de 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,12 +150,11 @@ AM_CONDITIONAL(HAVE_LIBSSL, test ! -z "$SSL_LIBS")
+
+
+ # See if we want libva support
+-# TODO: check if library actually exists
+ AH_TEMPLATE(CONFIG_LIBVA, [Build libva support])
+ AC_ARG_WITH(libva,
+-[ --with-libva build libva support],,)
++[ --without-libva disable support for libva],,)
+ if test "x$with_libva" != "xno"; then
+- AC_CHECK_LIB(va, vaInitialize,
++ AC_CHECK_LIB(va-x11, vaGetDisplay,
+ VA_LIBS="-lva -lva-x11"
+ [AC_DEFINE(CONFIG_LIBVA) CONFIG_LIBVA="true"], ,)
+ fi
+diff --git a/libvncclient/h264.c b/libvncclient/h264.c
+index 1d94454..c63a713 100644
+--- a/libvncclient/h264.c
++++ b/libvncclient/h264.c
+@@ -20,6 +20,10 @@
+ #ifdef LIBVNCSERVER_CONFIG_LIBVA
+
+ #include <X11/Xlib.h>
++#include <va/va_version.h>
++#if VA_CHECK_VERSION(0,34,0)
++#include <va/va_compat.h>
++#endif
+ #include <va/va_x11.h>
+
+ enum _slice_types {
+