summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-02 09:07:54 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-02 09:07:54 +0200
commitcdf5cca3d0be8fdaf05a0cc14626669c100bebff (patch)
tree60de4f1a095b55f6029f0126a63d392aba973909 /net-libs/miniupnpc/miniupnpc-1.9.20150917-r1.ebuild
parentdev-util/creduce: Update for fixed clang SLOT (diff)
downloadgentoo-cdf5cca3d0be8fdaf05a0cc14626669c100bebff.tar.gz
gentoo-cdf5cca3d0be8fdaf05a0cc14626669c100bebff.tar.bz2
gentoo-cdf5cca3d0be8fdaf05a0cc14626669c100bebff.zip
net-libs/miniupnpc: Install missing header file
Package-Manager: portage-2.2.20
Diffstat (limited to 'net-libs/miniupnpc/miniupnpc-1.9.20150917-r1.ebuild')
-rw-r--r--net-libs/miniupnpc/miniupnpc-1.9.20150917-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/miniupnpc-1.9.20150917-r1.ebuild b/net-libs/miniupnpc/miniupnpc-1.9.20150917-r1.ebuild
new file mode 100644
index 000000000000..0b88b59c1889
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-1.9.20150917-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/14"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 kernel_linux static-libs"
+
+RDEPEND=""
+DEPEND="kernel_linux? ( sys-apps/lsb-release sys-apps/which )"
+
+src_prepare() {
+ epatch_user
+
+ # These bins are not installed, upnpc-static requires building static lib
+ sed -i -e '/EXECUTABLES =/s/ upnpc-static listdevices//' Makefile || die
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d' \
+ Makefile || die
+ fi
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC AR
+ emake upnpc-shared $(use static-libs && echo upnpc-static)
+}
+
+src_test() {
+ emake -j1 HAVE_IPV6=$(usex ipv6 yes no) check
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}" \
+ INSTALLDIRLIB="${D}usr/$(get_libdir)" \
+ install
+
+ # oh no, a missing header! fixed upstream:
+ # https://github.com/miniupnp/miniupnp/commit/1315c473539d03
+ insinto /usr/include/miniupnpc
+ doins upnpdev.h
+
+ dodoc README Changelog.txt
+}