summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-25 20:29:06 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-25 21:04:35 +0100
commit1e8baecc04fbd88937861b2671dd5cdf8798f7c5 (patch)
tree48838aae9b0a8def5f6ee9b33bd205a194ca1499 /net-libs/miniupnpc
parentnet-misc/miniupnpd: Bump to 2.0.20180222 (diff)
downloadgentoo-1e8baecc04fbd88937861b2671dd5cdf8798f7c5.tar.gz
gentoo-1e8baecc04fbd88937861b2671dd5cdf8798f7c5.tar.bz2
gentoo-1e8baecc04fbd88937861b2671dd5cdf8798f7c5.zip
net-libs/miniupnpc: Bump to 2.0.20180222
Diffstat (limited to 'net-libs/miniupnpc')
-rw-r--r--net-libs/miniupnpc/Manifest1
-rw-r--r--net-libs/miniupnpc/miniupnpc-2.0.20180222.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/Manifest b/net-libs/miniupnpc/Manifest
index de2f1c56dda9..3fee459f5ec4 100644
--- a/net-libs/miniupnpc/Manifest
+++ b/net-libs/miniupnpc/Manifest
@@ -1,3 +1,4 @@
DIST miniupnpc-2.0.20170509.tar.gz 86055 BLAKE2B 7da640c4baac58aa26965a670877953b4c2d27aff08b604366bad6913b30c152d52120099f37c6250eeed97396ff412a4dd6000179070a82eebd3c052596b0d0 SHA512 71ec052ef6c8ad0d529e467ddae6eae19a93b9816174eeac753aa90e036cc2f00cf7e8d1cdb188ef8280849a988fe2995e37b63f8e2a361e021c1d1b306bff6f
DIST miniupnpc-2.0.20171212.tar.gz 86607 BLAKE2B fce582c4125192f74f6ffb174295020af1c9b574b2094f5565a5e49641820a2d9cef719de59cb94bfd207182505237c22cf58425e1a7b47f5dfe2eb84c07d3c5 SHA512 d25708f4e2ef7311878ba6d17cb506f4bfe5c9cc6b7a79e4168f143ca9da8b96beb018c42dd735f0b23806668eba2308b7de26d1b506d91c23f79c7ed77399a0
DIST miniupnpc-2.0.20180203.tar.gz 86772 BLAKE2B 6959d7033f12d3cbe52bbe1ec2178c068a448441d22501f44a7228b2050b53ff5e955d390ff03071e6f34df2a652040bf5ab23c59aca16dc4379e380dd46fea8 SHA512 b8ebf02ed01c5217a789397b7c224ba21d233cb544ccdfd907fb9c6f49adae6864eb17963b9b9f654ecf3fde864c191fd7d00c5cf614771a7137a030f341f226
+DIST miniupnpc-2.0.20180222.tar.gz 87018 BLAKE2B 656ae02ac6e462084252d95e579972d2bbaec24cf44b5910d4fc1a956723a8ed8fecaa428aea361a7ec8a3ff60b82e0d9468ac21d251c16ac8c2b52eafec6ab3 SHA512 0cceeedff6c584d2d7037ff91fbba0fe580fabfda810b9a9ed7c8d8495445339e3ff115d63d4429bcd3eff2b13b123e1bd5855ff1bc9dcd986b968a82c368591
diff --git a/net-libs/miniupnpc/miniupnpc-2.0.20180222.ebuild b/net-libs/miniupnpc/miniupnpc-2.0.20180222.ebuild
new file mode 100644
index 000000000000..3a1c24a1b100
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-2.0.20180222.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/16"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 kernel_linux static-libs"
+
+RDEPEND=""
+DEPEND="kernel_linux? ( sys-apps/lsb-release sys-apps/which )"
+
+src_prepare() {
+ eapply_user
+
+ # These bins are not installed, upnpc-static requires building static lib
+ sed -i -e '/EXECUTABLES =/s/ upnpc-static listdevices//' Makefile || die
+ # Prevent gzipping manpage.
+ sed -i -e '/gzip/d' Makefile || die
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d' \
+ Makefile || die
+ fi
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC AR
+ emake upnpc-shared $(usex static-libs upnpc-static '')
+}
+
+src_test() {
+ emake -j1 HAVE_IPV6=$(usex ipv6) check
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ INSTALLDIRLIB="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ dodoc README Changelog.txt
+}