summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-02-13 14:57:34 +0100
committerMichał Górny <mgorny@gentoo.org>2019-02-13 16:09:57 +0100
commita7eede626c2d327cb84eb5ef987b0e1c35579786 (patch)
treeae5ed551a4d9e8e38b67ce863b8b171a1cbdf67b /net-libs/miniupnpc
parentRevert "net-libs/miniupnpc: Bump to 2.1.20190210" (diff)
downloadgentoo-a7eede626c2d327cb84eb5ef987b0e1c35579786.tar.gz
gentoo-a7eede626c2d327cb84eb5ef987b0e1c35579786.tar.bz2
gentoo-a7eede626c2d327cb84eb5ef987b0e1c35579786.zip
net-libs/miniupnpc: Bump to 2.1.20190210
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/miniupnpc')
-rw-r--r--net-libs/miniupnpc/Manifest1
-rw-r--r--net-libs/miniupnpc/miniupnpc-2.1.20190210.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/Manifest b/net-libs/miniupnpc/Manifest
index a677cb63c060..3ad3871db3fb 100644
--- a/net-libs/miniupnpc/Manifest
+++ b/net-libs/miniupnpc/Manifest
@@ -1 +1,2 @@
DIST miniupnpc-2.0.20180503.tar.gz 88207 BLAKE2B 1d6c6396e805eae3c53263a6856cc119033a645da29471b31705fdee8465808361057804496821f845112fb8490d351f67a5d5c9e1fef522fc6e6df8d4ac34c1 SHA512 68dcf76fe62223de80610afd392f14f46af2465796c3d4d46daa0c6f1f7e99034368b2484e260e718d42eef480644a684e83d4c0f32a6108fdd544cfc48443a3
+DIST miniupnpc-2.1.20190210.tar.gz 94125 BLAKE2B 1cb8e4cd4d015d82eb15eec20e93b14a9f280aeabfc54e96ff9511db7fddf9713b9bffd0893c17f29beede29c6bfe73e6a459f7b20c9e4b33c88753b39cb7a0e SHA512 51f662c2a7a78cd99a793ff8b89097d895c80aaca696109c06106f8bb2601465207e068a410134cc66a61b4c0e11d4635bac6e9efdfe3fe8c4f813ac9e7a2fc2
diff --git a/net-libs/miniupnpc/miniupnpc-2.1.20190210.ebuild b/net-libs/miniupnpc/miniupnpc-2.1.20190210.ebuild
new file mode 100644
index 000000000000..b170db612f20
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-2.1.20190210.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 kernel_linux static-libs"
+
+RDEPEND=""
+DEPEND="kernel_linux? ( sys-apps/lsb-release sys-apps/which )"
+
+src_prepare() {
+ eapply_user
+
+ # These bins are not installed, upnpc-static requires building static lib
+ sed -i -e '/EXECUTABLES =/s/ upnpc-static listdevices//' Makefile || die
+ # Prevent gzipping manpage.
+ sed -i -e '/gzip/d' Makefile || die
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d' \
+ Makefile || die
+ fi
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC AR
+ emake upnpc-shared $(usex static-libs upnpc-static '')
+}
+
+src_test() {
+ emake -j1 HAVE_IPV6=$(usex ipv6) check
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ INSTALLDIRLIB="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ dodoc README Changelog.txt
+}