summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2022-01-30 06:00:00 +0000
committerJakov Smolić <jsmolic@gentoo.org>2022-02-01 19:10:23 +0100
commit3caf8a9b14e86287060937ca02e50ab37a5e2978 (patch)
tree352b38033033a04bfd83f1a29fec16ac9dc59ffa /net-libs/neon
parentnet-libs/neon: Delete no longer needed dependencies (diff)
downloadgentoo-3caf8a9b14e86287060937ca02e50ab37a5e2978.tar.gz
gentoo-3caf8a9b14e86287060937ca02e50ab37a5e2978.tar.bz2
gentoo-3caf8a9b14e86287060937ca02e50ab37a5e2978.zip
net-libs/neon: Use EAPI="8"
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'net-libs/neon')
-rw-r--r--net-libs/neon/neon-0.32.2.ebuild23
1 files changed, 10 insertions, 13 deletions
diff --git a/net-libs/neon/neon-0.32.2.ebuild b/net-libs/neon/neon-0.32.2.ebuild
index e380e3fd9cb2..af48c195905c 100644
--- a/net-libs/neon/neon-0.32.2.ebuild
+++ b/net-libs/neon/neon-0.32.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 2001-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="8"
inherit autotools libtool multilib-minimal
DESCRIPTION="HTTP and WebDAV client library"
-HOMEPAGE="https://notroj.github.io/neon/"
+HOMEPAGE="https://notroj.github.io/neon/ https://github.com/notroj/neon"
SRC_URI="https://notroj.github.io/neon/${P}.tar.gz"
LICENSE="GPL-2"
@@ -16,7 +16,7 @@ IUSE="doc expat gnutls kerberos libproxy nls pkcs11 ssl static-libs zlib"
RESTRICT="test"
BDEPEND="virtual/pkgconfig"
-RDEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
+DEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
!expat? ( dev-libs/libxml2:2=[${MULTILIB_USEDEP}] )
kerberos? ( virtual/krb5:0=[${MULTILIB_USEDEP}] )
libproxy? ( net-libs/libproxy:0=[${MULTILIB_USEDEP}] )
@@ -26,18 +26,18 @@ RDEPEND="expat? ( dev-libs/expat:0=[${MULTILIB_USEDEP}] )
app-misc/ca-certificates
net-libs/gnutls:0=[${MULTILIB_USEDEP}]
)
- !gnutls? (
- dev-libs/openssl:0=[${MULTILIB_USEDEP}]
- )
+ !gnutls? ( dev-libs/openssl:0=[${MULTILIB_USEDEP}] )
pkcs11? ( dev-libs/pakchois:0=[${MULTILIB_USEDEP}] )
)
zlib? ( sys-libs/zlib:0=[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}"
+RDEPEND="${DEPEND}"
MULTILIB_CHOST_TOOLS=(
/usr/bin/neon-config
)
+DOCS=( AUTHORS BUGS NEWS README.md THANKS TODO )
+
src_prepare() {
# Use CHOST-prefixed version of xml2-config for cross-compilation.
sed -e "s/AC_CHECK_PROG(XML2_CONFIG,/AC_CHECK_TOOL(XML2_CONFIG,/" -i macros/neon-xml-parser.m4 || die "sed failed"
@@ -91,15 +91,12 @@ multilib_src_install() {
emake DESTDIR="${D}" install-{config,headers,lib,man,nls}
if multilib_is_native_abi && use doc; then
- (
- docinto html
- dodoc -r doc/html/*
- )
+ dodoc -r doc/html
fi
}
multilib_src_install_all() {
- find "${D}" -name "*.la" -type f -delete || die
+ find "${ED}" -name "*.la" -delete || die
- dodoc AUTHORS BUGS NEWS README.md THANKS TODO
+ einstalldocs
}