summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/netwib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/netwib')
-rw-r--r--net-libs/netwib/Manifest2
-rw-r--r--net-libs/netwib/metadata.xml9
-rw-r--r--net-libs/netwib/netwib-5.39.0.ebuild60
3 files changed, 71 insertions, 0 deletions
diff --git a/net-libs/netwib/Manifest b/net-libs/netwib/Manifest
new file mode 100644
index 000000000000..41dde5cf381d
--- /dev/null
+++ b/net-libs/netwib/Manifest
@@ -0,0 +1,2 @@
+DIST netwib-5.39.0-doc_html.tgz 139572 SHA256 983cfc810e1a277b952158d4512c0fba36d3f2a83833213f338952ec0f2fdd18 SHA512 0920642854f71b4c20a8b0844d152aa1107b7cfe927524391626bac97185024261e0efbcb681b978fa612d04cb71a804c7ae604d2040c87d27d118c004940345 WHIRLPOOL c94d3b85781b825fd01b452829f49f99e8cf1bc4e256e22daba77632774add15ad496785cdf8e3a9c7206bd6f4ae2611820373afb7128e3ba574d6a92d74f03e
+DIST netwib-5.39.0-src.tgz 641757 SHA256 574d72d9bf8b0ed0c25a6b5e902b768727d404c44d570f769b4b1219aa66946f SHA512 eeb3c51c48ed22762fa0e4215dfd239fb97fc0b34f28382d77ad863ed1f2f4a1f26195517fcd26c4b1a96195c895bd7b7ed121af975b5dc49b1bc378b11ef234 WHIRLPOOL 540b330b76b3f0e82dbc6468d9b2c578e16c942b1bb6351a03f0ae9c11eee70a44c97f952bf212bcf68568dcf6952b946ae454addc3db605d7c0859289e340a4
diff --git a/net-libs/netwib/metadata.xml b/net-libs/netwib/metadata.xml
new file mode 100644
index 000000000000..f1a97d721422
--- /dev/null
+++ b/net-libs/netwib/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ntwib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-libs/netwib/netwib-5.39.0.ebuild b/net-libs/netwib/netwib-5.39.0.ebuild
new file mode 100644
index 000000000000..3750c3ee4fe8
--- /dev/null
+++ b/net-libs/netwib/netwib-5.39.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI=5
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="
+ http://www.laurentconstantin.com/en/netw/netwib/
+ http://ntwib.sourceforge.net/
+"
+SRC_URI="mirror://sourceforge/ntwib/${P}-src.tgz
+ doc? ( mirror://sourceforge/ntwib/${P}-doc_html.tgz )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc x86"
+IUSE="doc"
+
+DEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-src/src
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr/local:/usr:" \
+ -e "s:=ar:=$(tc-getAR):" \
+ -e "s:=ranlib:=$(tc-getRANLIB):" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ config.dat || die
+}
+
+src_configure() {
+ sh genemake || die
+}
+
+src_install() {
+ default
+ dodoc ../README.TXT
+ if use doc; then
+ mkdir "${D}"/usr/share/doc/${PF}/html
+ mv "${WORKDIR}"/${P}-doc_html/{index.html,${PN}} \
+ "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ cd "${S}"/..
+ dodoc \
+ doc/{changelog.txt,credits.txt,integration.txt} \
+ doc/{problemreport.txt,problemusageunix.txt,todo.txt}
+}