summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-01-25 17:47:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-01-25 17:49:02 +0100
commit23347c10191a773a12de6c87fde4cfd9687d238f (patch)
tree816926f131b41871c1f8f4071b201232e8b7d281 /net-libs/nghttp2
parentsys-libs/tevent: Removed old. (diff)
downloadgentoo-23347c10191a773a12de6c87fde4cfd9687d238f.tar.gz
gentoo-23347c10191a773a12de6c87fde4cfd9687d238f.tar.bz2
gentoo-23347c10191a773a12de6c87fde4cfd9687d238f.zip
net-libs/nghttp2: Bump to version 1.19.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.19.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 6292dde5116d..ddeac04b9404 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -2,3 +2,4 @@ DIST nghttp2-1.10.0.tar.gz 2086580 SHA256 192dc031e71e182240079befae9db7e64c9951
DIST nghttp2-1.17.0.tar.gz 2150137 SHA256 d7f1c3ea4ca8325998607140284e8640743366cc9ec87fbbcc11842e6106f2c4 SHA512 c2da7edfe802f8c3078f09b1fd31cbe18cf60779d3f3b1e5083bc4bdf12b180e9cd8e7785ee76820421de4ad8480e747b81feb15a5098002d40e7ab0bace3719 WHIRLPOOL fa08d48c7ba4cf8aa4ad8f29758102b489b7d2ff91c66882baf40d1d1a498f0f54111390674716baaa28d02531dbe07e4ef8933c9dd50c8dbfba17e158b29807
DIST nghttp2-1.18.0.tar.gz 2153032 SHA256 30b7a1fc21f58eadbcd124791dd7dbda50b9d4ad113b49d78d04ded49c22be8a SHA512 c23bce3866e243d4687d1af1caddd497f0813340a0748d5c13f096eaed827308689ab2d6e0a60d35971200017670d9020b11f9c7e55838953e564b419277904d WHIRLPOOL fc455a999a56f34a4b086330aab3528743243149aeab1a14b4ca57e010ac58bf2252376b9d1f876173e14beb8d1e5970cf42a72681159fcdc339084adb12a87c
DIST nghttp2-1.18.1.tar.gz 2148468 SHA256 131475e5dbfa1b497ec75637cf9d7b9149c51c83cbd6fc4e55bc6c9d12afa597 SHA512 d5634ae754eee55877a68a8ce72d62cc342fac466550811787364622e3236c6eaba750f46a22e460bae247e14238bfb6876e5d8eba57b0148ab8d9a7a8156612 WHIRLPOOL f422df813c06b73faec59ebb90a303d37c24e7a4f82f0431942472a6fdbb84ad871b2afc38f0b6eda39f1487280d88d975aafe6a513e36ae3e4d7effca9bfe8d
+DIST nghttp2-1.19.0.tar.gz 2159530 SHA256 b67946ad211aa3f7c91f4d866f47b056e821da8e31ab4636130d59be87f53016 SHA512 50f45082f725c237a0e1d25af57992b9cded6c9b68f0aa95c44c16eb4448e05b14e06c853032924d03034115286163de0ad684827cfa5d70896656868fdb4e01 WHIRLPOOL d6178a31aadfcfc3547ab4b0f58ba8f5b34a95ebc1168b7f03b4bfba58a03737b061eea020c264a2da882f0f6541620cd001e62919b82f5b1ada552402c2fab0
diff --git a/net-libs/nghttp2/nghttp2-1.19.0.ebuild b/net-libs/nghttp2/nghttp2-1.19.0.ebuild
new file mode 100644
index 000000000000..2c00bea1fbab
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.19.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI=6
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
+ utils? (
+ >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist,${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl[${MULTILIB_USEDEP}] )
+ >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
+ net-dns/c-ares:=[${MULTILIB_USEDEP}]
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}