summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-02-03 13:37:07 -0500
committerMike Frysinger <vapier@gentoo.org>2016-02-03 13:51:41 -0500
commit69fc6de62a9e4dbb4e5230a8a31c57901c72390f (patch)
tree0a0ba06b063a07940d38325d25092502ae6326df /net-libs/nghttp2
parentnet-libs/nghttp2: drop old <1.6.0 versions (diff)
downloadgentoo-69fc6de62a9e4dbb4e5230a8a31c57901c72390f.tar.gz
gentoo-69fc6de62a9e4dbb4e5230a8a31c57901c72390f.tar.bz2
gentoo-69fc6de62a9e4dbb4e5230a8a31c57901c72390f.zip
net-libs/nghttp2: version bump to 1.7.0 #573748
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/Manifest1
-rw-r--r--net-libs/nghttp2/nghttp2-1.7.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index 754c333ae4a1..b806676457b6 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1 +1,2 @@
DIST nghttp2-1.6.0.tar.gz 1983953 SHA256 c88012e87b80c055ddd2412efd7e96b9e8cfe0652c4b21083f2cb89b2f0d3a26 SHA512 32d5227a5ff037d50d93d43b1fdb0be51d9cca1e09dcc85320b8e09f82fdc658397ca58ca400595f138ca7b77f389d945e3562ab4074afd05e1c74eca4de2744 WHIRLPOOL 31102e596a9e93ca993cd9b8b04da6f51acb247803de16958501bdb6fe06e5bbc951430d2c2be1bd7fd1d9216d087d711de83bad6bb93eb70f4e4b8b0f864efb
+DIST nghttp2-1.7.0.tar.gz 2001726 SHA256 f0be9560baa30fc56bcce0151d88126d71b91815bb47076a8dd9ad2b9023ff49 SHA512 556a81ef9bad8a75a23b13532e6066af4412d79fa8dbde508ea893780bc9b19e0525674dc1cfb04b25cc48d62ae704737d6c4b1aa2b442a2be514b72490f6c1b WHIRLPOOL 138bb50c85ef7838be919989c032157ecedbfe1d5bf28633d5ee0c3d6f18dc7fa7525e185d476d146788466b58db0a2104054a1a28cb5152a8c4e9652fcb22ba
diff --git a/net-libs/nghttp2/nghttp2-1.7.0.ebuild b/net-libs/nghttp2/nghttp2-1.7.0.ebuild
new file mode 100644
index 000000000000..776f0f6311a0
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.7.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost:=[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0[-bindist] )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}