summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Leogrande <dark.knight.ita@gmail.com>2016-11-10 20:16:00 -0800
committerMichał Górny <mgorny@gentoo.org>2016-12-02 20:13:29 +0100
commit27a614a0ac1376d287e4ff6142f1dad61088ead8 (patch)
tree2f6ead48e688be1aa8d714cb0d4e4eeeffcdb544 /net-libs/nodejs/nodejs-7.2.0.ebuild
parentsys-kernel/gentoo-sources: Linux patch 4.8.12 (diff)
downloadgentoo-27a614a0ac1376d287e4ff6142f1dad61088ead8.tar.gz
gentoo-27a614a0ac1376d287e4ff6142f1dad61088ead8.tar.bz2
gentoo-27a614a0ac1376d287e4ff6142f1dad61088ead8.zip
net-libs/nodejs: add optional support for dtrace-based tracing
NodeJS supports dtrace-based tracing, that can be used by dev-util/systemtap and, more recently, dev-util/bcc. This support is forcibly disabled in nodejs ebuilds. This commit adds a systemtap USE flag to be able to turn on this support conditionally. The name of this flag matches the choice done for other ebuilds, like dev-db/mysql or app-emulation/qemu. Despite what has been done in those ebuilds, however, a dependency on dev-util/systemtap is not added: this is because, as of late, systemtap is not the only consumer of those traces anymore. Closes: https://github.com/gentoo/gentoo/pull/2803
Diffstat (limited to 'net-libs/nodejs/nodejs-7.2.0.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-7.2.0.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-libs/nodejs/nodejs-7.2.0.ebuild b/net-libs/nodejs/nodejs-7.2.0.ebuild
index 4e7689015852..739af4d843d6 100644
--- a/net-libs/nodejs/nodejs-7.2.0.ebuild
+++ b/net-libs/nodejs/nodejs-7.2.0.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl test"
+IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl systemtap test"
RDEPEND="icu? ( >=dev-libs/icu-56:= )
npm? ( ${PYTHON_DEPS} )
@@ -109,7 +109,7 @@ src_configure() {
"${PYTHON}" configure \
--prefix="${EPREFIX}"/usr \
--dest-cpu=${myarch} \
- --without-dtrace \
+ $(use_with systemtap dtrace) \
"${myconf[@]}" || die
}