summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-28 14:40:54 +0200
committerDavid Seifert <soap@gentoo.org>2023-08-28 14:40:54 +0200
commit65a50a61ad81413be21d2e08e532c9f24875db8e (patch)
tree134f5ec92af90db600296eca69dc90524d063e5a /net-libs/ntirpc/ntirpc-5.0.ebuild
parentsys-block/di: add 4.52 (diff)
downloadgentoo-65a50a61ad81413be21d2e08e532c9f24875db8e.tar.gz
gentoo-65a50a61ad81413be21d2e08e532c9f24875db8e.tar.bz2
gentoo-65a50a61ad81413be21d2e08e532c9f24875db8e.zip
net-libs/ntirpc: add 5.0
Bug: https://bugs.gentoo.org/902995 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc/ntirpc-5.0.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-5.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-5.0.ebuild b/net-libs/ntirpc/ntirpc-5.0.ebuild
new file mode 100644
index 000000000000..c6d615747227
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-5.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu:=
+ rdma? ( sys-cluster/rdma-core )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-include-assert.h.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS=$(usex gssapi)
+ -DUSE_RPC_RDMA=$(usex rdma)
+ )
+ cmake_src_configure
+}