summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/openmq-cclient
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/openmq-cclient')
-rw-r--r--net-libs/openmq-cclient/Manifest1
-rw-r--r--net-libs/openmq-cclient/files/Makefile.in-469
-rw-r--r--net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch13
-rw-r--r--net-libs/openmq-cclient/metadata.xml19
-rw-r--r--net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild79
5 files changed, 181 insertions, 0 deletions
diff --git a/net-libs/openmq-cclient/Manifest b/net-libs/openmq-cclient/Manifest
new file mode 100644
index 000000000000..ee94b1d18684
--- /dev/null
+++ b/net-libs/openmq-cclient/Manifest
@@ -0,0 +1 @@
+DIST openmq4.4u1b7-final-source.zip 6892740 RMD160 30c1f1e4b78a8010aeb5a6b8436f46db8a15a4ae SHA1 7feb726d7401eae48328d6d97e3a4dac6dd3c15a SHA256 56e3c5e2c53cee12076f4974236c7f72a5069bb7034b633747c3721d42d57346
diff --git a/net-libs/openmq-cclient/files/Makefile.in-4 b/net-libs/openmq-cclient/files/Makefile.in-4
new file mode 100644
index 000000000000..8d536b927566
--- /dev/null
+++ b/net-libs/openmq-cclient/files/Makefile.in-4
@@ -0,0 +1,69 @@
+prefix=@prefix@
+exec_prefix=@exec_prefix@
+libdir=@libdir@
+includedir=@includedir@
+
+top_srcdir=@top_srcdir@
+top_builddir=@top_builddir@
+
+CC = @CC@
+CXX = @CXX@
+LIBTOOL = @LIBTOOL@
+
+CFLAGS = @CFLAGS@
+CXXFLAGS = @CXXFLAGS@
+LDFLAGS = @LDFLAGS@
+
+LTCC = $(LIBTOOL) --mode=compile --tag=CC $(CC)
+LTCXX = $(LIBTOOL) --mode=compile --tag=CXX $(CXX)
+LTLD = $(LIBTOOL) --mode=link --tag=CXX $(CXX)
+
+NS_S_PR_CFLAGS = $(shell pkg-config --cflags nss nspr)
+NS_S_PR_LIBS = $(shell pkg-config --libs nss nspr)
+
+SRCS = $(shell find "$(top_srcdir)" -name examples -prune -o -type f '(' -name '*.cpp' -o -name '*.c' -not -name '*Test*' ')')
+LTOBJS = $(subst .c,.lo,$(subst .cpp,.lo,$(SRCS)))
+
+HDRS = $(top_srcdir)/cshim/mq/xa.h $(shell find "$(top_srcdir)"/cshim -type f -name 'mq*.h')
+INSTHDRS = $(subst $(top_srcdir)/cshim,$(DESTDIR)$(includedir),$(HDRS))
+
+LTLIBRARY = libmqcrt.la
+INSTLTLIBRARY = $(DESTDIR)$(libdir)/$(LTLIBRARY)
+
+.SUFFIXES:
+.SUFFIXES: .cpp .c .lo
+
+default: all
+
+all: $(LTLIBRARY)
+
+Makefile: Makefile.in
+ $(top_builddir)/config.status $@
+
+.cpp.lo:
+ $(LTCXX) -o $@ $(NS_S_PR_CFLAGS) $(CXXFLAGS) -c $<
+
+.c.lo:
+ $(LTCC) -o $@ $(NS_S_PR_CFLAGS) $(CFLAGS) -c $<
+
+VERSIONNUMBER = $(shell { echo '#include "cshim/mqversion.h"'; echo '-version-number MQ_VMAJOR:MQ_VMINOR:MQ_VMICRO'; } | ${CC} -E - | grep version-number)
+
+$(LTLIBRARY): $(LTOBJS)
+ version=` \
+ { echo '#include "cshim/mqversion.h"' \
+ ; echo '-version-number MQ_VMAJOR:MQ_VMINOR:MQ_VMICRO' \
+ ; } \
+ | ${CC} -E - \
+ | grep version-number \
+ ` \
+ && $(LTLD) -o $@ --no-undefined $${version} $(CXXFLAGS) $(NS_S_PR_LIBS) $(LDFLAGS) -rpath $(libdir) $?
+
+$(INSTLTLIBRARY): $(LTLIBRARY)
+ $(top_srcdir)/install-sh -d "$(dir $@)"
+ $(LIBTOOL) --mode=install cp $(LTLIBRARY) $@
+
+$(DESTDIR)$(includedir)/%: $(top_srcdir)/cshim/%
+ $(top_srcdir)/install-sh -d "$(dir $@)"
+ cp -f "$<" "$@"
+
+install: $(INSTLTLIBRARY) $(INSTHDRS)
diff --git a/net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch b/net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch
new file mode 100644
index 000000000000..e9a9d7281738
--- /dev/null
+++ b/net-libs/openmq-cclient/files/openmq-cclient-4.4.1-aix-gcc.patch
@@ -0,0 +1,13 @@
+Seems they've never seen gcc on AIX.
+
+--- cshim/mqbasictypes.h.orig 2010-03-01 18:00:38 +0100
++++ cshim/mqbasictypes.h 2010-03-01 18:00:58 +0100
+@@ -64,7 +64,7 @@
+ #endif
+ #endif
+
+-#if (defined(__IBMC__) || defined (__IBMCPP__)) && defined(__unix__)
++#if ((defined(__IBMC__) || defined (__IBMCPP__)) && defined(__unix__)) || defined(_AIX)
+ #ifndef AIX
+ #define AIX
+ #endif
diff --git a/net-libs/openmq-cclient/metadata.xml b/net-libs/openmq-cclient/metadata.xml
new file mode 100644
index 000000000000..dd4cd930c2f0
--- /dev/null
+++ b/net-libs/openmq-cclient/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>haubi@gentoo.org</email>
+ <name>Michael Haubenwallner</name>
+ </maintainer>
+ <longdescription lang="en">
+ Open message queue is an enterprise quality, production ready, scalable
+ messaging server. It provides a complete Java Message Service (JMS)
+ implementation for message oriented system integration. In addition,
+ Open MQ provides the additional enterprise features that are necessary
+ for enterprise deployments, large and small. It gets its roots from Java
+ Message Queue and provides all the features, functions and capabilities
+ of the currently available licensed product: Java System Message Queue.
+ These ebuilds install the c-client library only.
+ </longdescription>
+</pkgmetadata>
+
diff --git a/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild b/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild
new file mode 100644
index 000000000000..37345f651cc8
--- /dev/null
+++ b/net-libs/openmq-cclient/openmq-cclient-4.4.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit versionator autotools
+
+DESCRIPTION="C-Client Library for Open Source Java Message Service (JMS)"
+HOMEPAGE="https://mq.dev.java.net/"
+
+# set this for rc and final versions to the build-number of open-mq
+MY_BUILDV="b7"
+
+LICENSE="|| ( CDDL GPL-2-with-linking-exception )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix"
+IUSE=""
+
+if [[ $(x=( $(get_all_version_components) ); echo ${x[3]}) == '.' ]]; then
+ MY_PV=$(replace_version_separator 2 'u' $(get_version_component_range 1-3))
+else
+ MY_PV=$(get_version_component_range 1-2)
+fi
+
+if [[ ${PV} == *rc* || ${PV} == *beta* ]]; then
+ for x in $(get_version_components); do
+ if [[ ${x} == rc* ]]; then
+ MY_BUILDV="${MY_BUILDV}-${x}"
+ break
+ fi
+ if [[ ${x} == beta* ]]; then
+ MY_BUILDV=b${x#beta}
+ break
+ fi
+ done
+else
+ MY_BUILDV="${MY_BUILDV}-final"
+fi
+
+MY_ZIPV=$(replace_version_separator 1 _ $(get_version_component_range 1-2))
+SRC_URI="http://download.java.net/mq/open-mq/${MY_PV}/${MY_BUILDV}/openmq${MY_ZIPV}-source.zip -> openmq${MY_PV}${MY_BUILDV}-source.zip"
+
+RDEPEND="
+ dev-libs/nss
+ dev-libs/nspr
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-arch/unzip
+"
+
+S="${WORKDIR}/mq/src/share/cclient"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-aix-gcc.patch
+
+ einfo "avoiding potential conflict with <xa.h>"
+ mkdir cshim/mq || die
+ mv cshim/xa.h cshim/mq/ || die
+ ln -s mq/xa.h cshim/xa.h || die
+ sed -i -e 's,"xa.h","mq/xa.h",' cshim/mqxaswitch.h || die
+ eend $?
+
+ cp "${FILESDIR}"/Makefile.in-4 Makefile.in || die
+ cat > configure.ac <<-EOF
+ AC_INIT(local-libtool, 0)
+ AC_PROG_CC
+ AC_PROG_CXX
+ AC_PROG_LIBTOOL
+ AC_OUTPUT(Makefile)
+ EOF
+
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}