summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-03-10 15:29:16 -0400
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-10 21:44:47 +0100
commit28bdaa99c48bce0ceb44d1052add81fa576b2dae (patch)
tree91c503de7610489b1badfff4b8f22f01d30c61ad /net-libs/qxmpp
parentnet-libs/qxmpp: drop the obsolete 1.0.1 version (diff)
downloadgentoo-28bdaa99c48bce0ceb44d1052add81fa576b2dae.tar.gz
gentoo-28bdaa99c48bce0ceb44d1052add81fa576b2dae.tar.bz2
gentoo-28bdaa99c48bce0ceb44d1052add81fa576b2dae.zip
net-libs/qxmpp: update the 9999 ebuild
* EAPI 7 * `cmake` eclass instead of `cmake-utils` * minor fixes to mirror the ones for the versioned ebuilds Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/qxmpp')
-rw-r--r--net-libs/qxmpp/qxmpp-9999.ebuild36
1 files changed, 16 insertions, 20 deletions
diff --git a/net-libs/qxmpp/qxmpp-9999.ebuild b/net-libs/qxmpp/qxmpp-9999.ebuild
index b1973ffc3cce..453364d6055c 100644
--- a/net-libs/qxmpp/qxmpp-9999.ebuild
+++ b/net-libs/qxmpp/qxmpp-9999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-EGIT_REPO_URI="https://github.com/qxmpp-project/qxmpp"
-
-inherit git-r3 cmake-utils
+inherit git-r3 cmake
DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework"
HOMEPAGE="https://github.com/qxmpp-project/qxmpp/"
+EGIT_REPO_URI="https://github.com/qxmpp-project/qxmpp"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -26,17 +25,22 @@ RDEPEND="
vpx? ( media-libs/libvpx:= )
"
DEPEND="${RDEPEND}
- dev-util/cmake
test? ( dev-qt/qttest:5 )
+"
+BDEPEND="
doc? ( app-doc/doxygen )
"
src_prepare() {
# requires network connection, bug #623708
- sed -e "/qxmppiceconnection/d" \
- -i tests/CMakeLists.txt || die "failed to drop single test"
-
- cmake-utils_src_prepare
+ sed \
+ -e "/qxmppiceconnection/d" \
+ -e "/qxmppserver/d" \
+ -e "/qxmpptransfermanager/d" \
+ -i tests/CMakeLists.txt \
+ || die "failed to drop certain network tests"
+
+ cmake_src_prepare
}
src_configure() {
@@ -44,20 +48,12 @@ src_configure() {
-DBUILD_DOCUMENTATION=$(usex doc)
-DBUILD_EXAMPLES=OFF
-DBUILD_TESTS=$(usex test)
+ -DBUILD_INTERNAL_TESTS=$(usex test)
-DWITH_OPUS=$(usex opus)
-DWITH_SPEEX=$(usex speex)
-DWITH_THEORA=$(usex theora)
-DWITH_VPX=$(usex vpx)
)
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- if use doc; then
- # Use proper path for documentation
- mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die "doc mv failed"
- fi
+ cmake_src_configure
}